URL Rewrite Not Working

Discussion in 'ISPConfig 3 Priority Support' started by Kevin S, May 27, 2020.

  1. Kevin S

    Kevin S New Member

    I have installed Really Simple SSL plugin (https://wordpress.org/plugins/really-simple-ssl/) and mod_rewrite is enabled but for some reason it does not force redirection. I have the following entries made to the .htaccess file.

    # BEGIN rlrssslReallySimpleSSL rsssl_version[3.3.3]
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTPS} !=on [NC]
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
    # END rlrssslReallySimpleSSL
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does the server really use Apache web server and not Nginx?
    Did you enable SSL in ISPConfig and are you able to use the website over SSL?
    Then you should take care to not use SSL redirect options in ISPConfig together with that plugin, either sue ISPConfig SSL redirect or that plugin but not both.
  3. Kevin S

    Kevin S New Member

    It is an Apache webserver. Yes, I have installed the SSL using the Let's Encrypt SSL option. Rewrite HTTP to HTTPS option is turned off. The site is accessible with both HTTP and HTTPs
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you change the WordPress URL in the WordPress settings to https too, if not, do that?

    Personally, I won't use such a plugin, each additional plugin will just slow down your site. Instead, better turn on the HTTP to https rewrite in ISPConfig and change the URL in WordPress from HTTP to https.

Share This Page