URL issue with mailman

Discussion in 'Installation/Configuration' started by kiar, Oct 8, 2016.

  1. kiar

    kiar New Member

    Hello,
    I have a small url problem with mailman since the update this summer from our server debian wheezy --> debian jessie.
    We can send or receive emails on a list, and I can add and configure a list with my browser, but I cannot moderate a new list anymore at the address list.domain.com/cgi-bin/mailman/admindb/MYLIST : everytime I clic the submit button, it throwns a 404 error and show the page at the false url domain.com/cgi-bin/mailman/admindb/MYLIST ( without subdomain list ). On this page, the LOGOUT link is also incorrect.
    This problem does not appear for the old lists, what I have created before the update to jessie, but only foe the new lists.

    I have checked /etc/mailman/mm_cfg.py, and the config/url are correct.
    I tried to copy the config from an "old" list to a "new" list, but it didn't change anything :
    Code:
    config_list -o config.txt OLDLISTNAME
    EDIT + CHANGE config.txt
    config_list -i config.txt NEWLISTNAME
    Maybe it is a problem with my apache config, but I can't find it :
    Code:
    /etc/apache2/conf.d# grep -v '^#' mailman.conf 
    ScriptAlias /cgi-bin/mailman/ /usr/lib/cgi-bin/mailman/
    Alias /pipermail/ /var/lib/mailman/archives/public/
    Alias /images/mailman/ /usr/share/images/mailman/
    <Directory /usr/lib/cgi-bin/mailman/>
        AllowOverride None
        Options ExecCGI
        AddHandler cgi-script .cgi
        Require all granted
    </Directory>
    <Directory /var/lib/mailman/archives/public/>
        Options FollowSymlinks
        AllowOverride None
        Require all granted
    </Directory>
    <Directory /usr/share/images/mailman/>
        AllowOverride None
        Require all granted
    </Directory>
    
    By the way, the logo don't appear on the mailman config page, but it's probably another problem, and not so important ...
    Any idea to solve this ?
    Thanks !
     
  2. kiar

    kiar New Member

    An update to ispconfig 3.1 did not solved the issue.
     
  3. kiar

    kiar New Member

    Update to Ispconfig 3.1.1p1 didn't solved the issue too ...
    Am I the only one with this problem ?
    After the update on 3.1.1p1 I have created a new test list in mailman, and the link on the moderation page are still false.
     
  4. kiar

    kiar New Member

    Ok, I found how to solve it :
    Code:
    withlist -l -r fix_url LISTNAME
    But I have to do it for all new lists.
     
  5. Jesse Norell

    Jesse Norell Active Member

    File a bug in the issue tracker if appropriate (eg. check to make sure there's not one for that already).
     
  6. kiar

    kiar New Member

Share This Page