[URGENT] : no more "sites" since update

Discussion in 'Installation/Configuration' started by mumbly, Jul 13, 2008.

  1. mumbly

    mumbly New Member

    Hi,
    i've done the update from ispconfig 2.2.23 to 2.2.24 on my Ubuntu 8.04 hardy heron server
    Since this, some sites point to the "It works !" apache2 page... AND when i connect to ispconfig admin panel, i can see Clients and Sites. But if i click on the custumer's name/Site settings tab "Gestion de site" (in french), there is nothing !!!

    I can see columns IP - Host Domain but there is several empty lines with nothing inside. This is the same thing for EVERY sites !

    Hope i explain well : can you help me ???
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Did you run the setup script more then once eg. because it stopped during update?
    2) Any errors during update?
     
  3. mumbly

    mumbly New Member

    1) no stop during update
    2) just ran once !
    3) no errors ...

    [sites running again sionce i have reput the Vhosts_ispconfig.conf backup in /etc/apache2/vhost]
     
  4. mumbly

    mumbly New Member

    It seems it's a SQL base problem ... I can say that because clients and sites seem no more "synced" and one of my site give an sql error :
    Unknown column 'domaintype' in 'where' clause ...
    Hum ... am i right ?
    And the domain names in the "site ISP" tab are ALL gone !

    [UPDATE] : isp_isp_web base is empty !!!
    What happened ?
     
    Last edited: Jul 13, 2008
  5. mumbly

    mumbly New Member

    OK ... all is ok now ... but i had to put my isp_isp_web backup because it was all empty after the update from 2.2.23 to 2.2.24 ...
    I don't know what happened ...
    When you have time, can you send me some advices about that ? thanx !
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    df -h
    ?
     
  7. mumbly

    mumbly New Member

    $ df -h
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda2 146G 62G 78G 45% /
    varrun 498M 132K 497M 1% /var/run
    varlock 498M 0 498M 0% /var/lock
    udev 498M 20K 498M 1% /dev
    devshm 498M 0 498M 0% /dev/shm
    /dev/sda1 38M 11M 26M 30% /boot
     
  8. gamma1it

    gamma1it New Member

    Bind update stopped Web server

    I am having a similar problem. I did the bind update on July 11th, after the update all was still working. I then rebooted the machine and the web server in ISP config control panel said web server offline and the sites were not on the web. I then went to update ispconfig and got an error that pointed to the httpd.conf file. I commented out the last include line ( Include /etc/apache2/vhosts/Vhosts_ispconfig.conf )and tried to update ISP config again. The update seemed okay this time and the web server ran but I got the Apache error screen for all site names. Today the server sudenly rebooted itself (code 15) and since then I no longer even get the Appache error message and the Web server says offline but is set to on. I have uncommented the line in the httpd.conf but its still ofline. All my sites are down and like an idiot.........I have no back up just RAID.

    In my warn logs (SuSe 10.3) I see this message "zone my-domain.tld/IN: NS 'ns1.my-domain.tld' has no address records (A or AAAA)"

    I still swear by ISP config and have a great deal of confidence in your support forums. Thanks in advance for all your efforts to get this resolved.

    Aaron
    :eek:
     
  9. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log?
     
  10. gamma1it

    gamma1it New Member

    Web server stopped in ISPConfig

    Hi Falko, nice to have your assistance again. Here is the end of my apache error log (found in /var/log/apache2/error_log) The first error (PHP) has been occurring since may but did not seem to have much of impact. The only trouble I was having was with the FTP.


    [Fri Jul 11 12:17:37 2008] [error] an unknown filter was not added: PHP
    [Fri Jul 11 12:18:27 2008] [error] an unknown filter was not added: PHP
    [Fri Jul 11 12:18:27 2008] [error] an unknown filter was not added: PHP
    [Fri Jul 11 12:18:33 2008] [error] an unknown filter was not added: PHP
    [Fri Jul 11 12:18:33 2008] [error] an unknown filter was not added: PHP
    [Fri Jul 11 12:18:35 2008] [error] an unknown filter was not added: PHP
    [Fri Jul 11 12:18:35 2008] [error] an unknown filter was not added: PHP
    [Fri Jul 11 12:20:49 2008] [notice] caught SIGTERM, shutting down
    [Fri Jul 11 12:58:49 2008] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
    [Fri Jul 11 12:58:49 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Fri Jul 11 12:58:50 2008] [notice] Apache/2.2.4 (Linux/SUSE) mod_ssl/2.2.4 OpenSSL/0.9.8e PHP/5.2.6 with Suhosin-Patch configured -- resuming normal operations
    [Fri Jul 11 12:58:59 2008] [notice] caught SIGTERM, shutting down
    [Fri Jul 11 12:58:59 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
    [Fri Jul 11 12:58:59 2008] [notice] Apache/2.2.4 (Linux/SUSE) mod_ssl/2.2.4 OpenSSL/0.9.8e PHP/5.2.6 with Suhosin-Patch configured -- resuming normal operations
    [Fri Jul 11 12:59:20 2008] [error]

    I deleted the rest for this post

    You guys are brilliant, thanks again!

    Regards,

    Aaron:confused:
     
    Last edited: Dec 1, 2008
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, this are all no serious errors. Doyou get any error message when you execute:

    httpd -t
     
  12. gamma1it

    gamma1it New Member

    Hi Till,

    I do get an error. "bad user name web1_myfirstsitesfirstuser" also the apache error log never generated anything but the 1st PHP error (repeatedly) until the update for bind was applied.

    Thanks for all your help.

    Aaron

     
    Last edited: Jul 15, 2008
  13. falko

    falko Super Moderator ISPConfig Developer

    Is web1_myfirstsitesfirstuser listed in /etc/passwd?
     
  14. gamma1it

    gamma1it New Member

    Web server stopped in ISPConfig

    "web1_myfirstsitesfirstuser:x:10001:10001:admin:/srv/www/web1:/bin/bash" is what is listed

    Vielen Dank Falco :eek:

    Regards,

    Aaron
     
  15. falko

    falko Super Moderator ISPConfig Developer

    Is web1_myfirstsitesfirstuser listed also in /etc/shadow and your Vhosts_ispconfig.conf?
     
  16. gamma1it

    gamma1it New Member

    Web server stopper in Isp Config

    Hi Falco,

    Vhosts_ispconfig.conf: ( most recent as there are several in the folder.) "SuexecUserGroup web1_ myfirstsitesfirstuser web1"

    and /etc/shadow:
    +
    web1_myfirstsitesfirstuser:]oHOH.hv2ABa.:"*"
    I notice a plus sign in the line above web1_myfirstsitesfirstuser:]oHOH.hv2ABa.:*.* but not above any other entries.

    Thanks again,

    Aaron

     
    Last edited: Nov 17, 2008
  17. falko

    falko Super Moderator ISPConfig Developer

    Can you remove that plus sign and try again?
     
  18. gamma1it

    gamma1it New Member

    Good morning Falko,

    I removed the plus sign and from the console excuted "etc/init.d/ispconfig_server restart", then I opened up the ISPConfig control panel and checked my services. Web server is still offline.(apache will not start), I tried to restart the service from the ISPConfig control panel but no such luck. I do have remote access and it is working. I can let you in the server if you like.

    If I don't talk to you later, Have a great weekend.

    Gratefully,

    Aaron;)

     
  19. falko

    falko Super Moderator ISPConfig Developer

    Can you log in with web1_myfirstsitesfirstuser on the shell?
     
  20. gamma1it

    gamma1it New Member

    Web server stopped, user password changed

    Hi Falko,

    I could not login with the user. It seems the password had changed? I have reset it to what it was and restarted appache. Would you beleive......it works now. I must admit, I am confused.........how did the password change? How come apache went down because one users password changed? Regardless......You guys are awsome. You have saved my hide again.

    Big thanks and huge respect to you guys!:D

     

Share This Page