URGENT! Ispconfig stopped worked from a distro upgrade

Discussion in 'Installation/Configuration' started by roboto, Nov 21, 2007.

  1. roboto

    roboto New Member

    Hi, to all

    I upgraded last night my ubuntu from dapper to feisty. At first everything was fine but then i discovered that ispconfig was dead, i thought a simply upgrade would be ok... wrong. since i start the upgrade the ispconfig installation directory in the /root has benn deleted.

    i managed to get apache working commenting out the ispconfig custom log in apache2.conf. the problem is that the email aren't delivered to Mildir. From the mail logs everything seems fine, no errors or warning but nothing is delivered.

    so, how can i fix this with or withiut Ispconfig?
    a new installation will remove my site, emails account, mysql records.. or it will keeps everything like an upgrade?

    PLease answer, it's UUUUUUURGENT!!!
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    please run:

    mkdir /root/ispconfig
    ln -sf /bin/bash /bin/sh

    and then unpack the ispconfig installer again and run the setup script.
     
  3. roboto

    roboto New Member

    yep, the upgrade process has started but then i get theese errors:

    Code:
    ./configure:Error: APACI failed
    ERROR: Could not configure Apache
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!
    
    
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please post the errors before the line:

    ./configure:Error: APACI failed
     
  5. roboto

    roboto New Member

  6. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Thats why I ppsted two commands ;)
     
  7. roboto

    roboto New Member

    still doesn't work. At the end of the installation procedure i get this

    Code:
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    
    
     
  8. roboto

    roboto New Member

    and also

    Code:
    root@mondo:~/install_ispconfig # /etc/init.d/ispconfig_server restart
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Shutting down ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Starting ISPConfig system...
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    ISPConfig system is now up and running!
    
    
     
  9. roboto

    roboto New Member

    i copied de server.crt and server.key into /ispconfig/httpd/conf/ and it works.

    thanx for the help :)
     

Share This Page