Upload a little file by the Ftp client and the file uploaded is equal to ZERO byte

Discussion in 'General' started by vaio1, Dec 4, 2009.

  1. vaio1

    vaio1 ISPConfig Developer

    Hi guys,

    why I cannot upload my own file in a profile?

    I have uploaded a little file by the Ftp client and the file uploaded is equal to ZERO byte.

    The ISPConfig alerts me that the profile is near to the end of the space but I can see that I have about 50MB and the file that I want to upload is about 50KB!

    thanks in advance.
     
  2. falko

    falko Super Moderator

    Did you check your quota settings with
    Code:
    repquota -avug
    ?
     
  3. vaio1

    vaio1 ISPConfig Developer

    how have I read it?

    Code:
    web45     --  310128 1280000 1281024          26994     0     0 
    
     
  4. falko

    falko Super Moderator

    What's the output of
    Code:
    repquota -avug | grep web45
    ?

    Which distribution do you use? Are there any ProFTPd errors in your logs? Do you use a firewall?
     
  5. vaio1

    vaio1 ISPConfig Developer

    # repquota -avug | grep web45
    web45_user1 -- 200 102400 103424 47 0 0
    web45_user2 -- 448 102400 103424 48 0 0
    web45_user3 -- 484 0 0 49 0 0
    web45_user4 -- 112 102400 103424 13 0 0
    web45_user5 -- 288 102400 103424 43 0 0
    web45_user6 +- 253152 102400 103424 19:07 28023 0 0
    web45 -- 254584 1280000 1281024 26997 0 0
     
  6. falko

    falko Super Moderator

    web45_user6 is over quota. Is that the user that's having the problem?
     
  7. vaio1

    vaio1 ISPConfig Developer

    yes it is.

    is there a way to alert the users about the quota?

    thanks
     
  8. falko

    falko Super Moderator

    The administrator should get a quota report twice a day - he can then inform the users if necessary.
     
  9. vaio1

    vaio1 ISPConfig Developer

    Hi again Falko,

    I have update the Webspace MB but I continue to get the same problem. When I try to upload a file the file transfered is equal to zero. Why?!

    The FTP Client says:

    thanks again
     
  10. matrixn

    matrixn New Member

    what is the output of quotacheck -avugm?
     
    Last edited: Dec 9, 2009
  11. vaio1

    vaio1 ISPConfig Developer

    Code:
    # quotacheck -avugm
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.
    
     
  12. matrixn

    matrixn New Member

    do quotaoff -avug and then quotacheck -avugm and after finishing his checking quotaon -avug

    this should update the quotadb and if you have raised the storage space should let you upload via ftp.
     
  13. vaio1

    vaio1 ISPConfig Developer

    Nothing to do. The problem persist.
     
  14. matrixn

    matrixn New Member

    try to turn off your quota and upload your file... see if that works. You can turn off quota by quotaoff -avug and turn it on by quotaon -avug
     
  15. vaio1

    vaio1 ISPConfig Developer

    Without Quota it works! and WITH Quota 52 Transfer aborted. Disk quota exceeded
    Now?
     
  16. matrixn

    matrixn New Member

    i think that the file you are trying to upload is bigger and the size of quota for respective user is smaller than you need.. try to set bigger value for the user. ex: 2000 (2000mb ~ 2gb) and then deactivate quota, do a quotacheck and activate again.


    p.s what is your distro?
     
  17. vaio1

    vaio1 ISPConfig Developer

    No at all.
    The file that I have tried to upload is 25KB and the user space is about 3 GB. Seems sufficient, or not :p ?

    I have already deactivated the quota, done a quotacheck and activated it again.

    I have a CentOs 5.4
     
  18. vaio1

    vaio1 ISPConfig Developer

    Look at this user's quota:
    Code:
    *** Report for user quotas on device /dev/mapper/VolGroup01-LogVol00
    Block grace time: 7days; Inode grace time: 7days
                            Block limits                File limits
    User            used    soft    hard  grace    used  soft  hard  grace
    ----------------------------------------------------------------------
    web2_user +-  304376  102400  103424  5days   27964     0     0   
    Is this correct?
     
  19. falko

    falko Super Moderator

    That user is over quota as well. Try to set a bigger quota, or delete files (e.g. log files) and directories of that user that aren't needed anymore.
     
  20. vaio1

    vaio1 ISPConfig Developer

    No it is not possible.

    How can I get the real used space by the user?

    thanks
     

Share This Page