Upgrading to PHP 5 on CentOS

Discussion in 'Installation/Configuration' started by Matthes, Jul 24, 2008.

  1. Matthes

    Matthes New Member

    I'm having all kinds of trouble.

    Code:
    --> Processing Conflict: php-pecl-apc conflicts php-mmcache
    --> Processing Conflict: php-eaccelerator conflicts php-mmcache
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package lm_sensors.i386 0:2.8.7-2.40.5 set to be updated
    ---> Package postgresqlclient7.i386 0:7.4.19-1.el4s1.1 set to be updated
    --> Running transaction check
    --> Processing Conflict: php-pecl-apc conflicts php-eaccelerator
    --> Processing Dependency: php = 4.3.9 for package: php-mmcache
    --> Processing Dependency: libssh2.so for package: php-pecl-ssh2
    --> Processing Dependency: libssh2 for package: php-pecl-ssh2
    --> Processing Dependency: php-pecl(Xdebug) for package: php-pear-PHPUnit2
    --> Processing Conflict: php-pecl-apc conflicts php-mmcache
    --> Processing Conflict: php-eaccelerator conflicts php-mmcache
    --> Finished Dependency Resolution
    Error: php-pecl-apc conflicts with php-eaccelerator
    Error: Missing Dependency: php = 4.3.9 is needed by package php-mmcache
    Error: Missing Dependency: libssh2.so is needed by package php-pecl-ssh2
    Error: Missing Dependency: libssh2 is needed by package php-pecl-ssh2
    Error: Missing Dependency: php-pecl(Xdebug) is needed by package php-pear-PHPUnit2
    Error: php-pecl-apc conflicts with php-mmcache
    Error: php-eaccelerator conflicts with php-mmcache
    
    Could anyone give me some good instruction on how to upgrade to PHP5 and mySQL5?
     
  2. falko

    falko Super Moderator

    I'd uninstall php-mmcache and try to upgrade again.
     

Share This Page