Upgrading Questions

Discussion in 'Installation/Configuration' started by jason.wallace, Feb 4, 2009.

  1. jason.wallace

    jason.wallace New Member

    All,

    I have a production installation of ISPConfig 2.2.2 on Ubuntu 6.06LTS, simply for the ease of adding email users and spam filtering. It's been running a long time quit well.

    Spam is becoming more and more of a problem and I'm thinking that updating ISPConfig (which as I understand will also update spamassassin...) is what I need to do. I do not want to upgrade Ubuntu, unless there's no way out.

    I have read of instances where the updated clam av will not compile on Ubuntu 6.06 because of an older version of gcc or something.

    I really can not destroy this server! Can someone summarize what's required to upgrade to the latest ISPConfig, spamassassin, etc (ie, hold my hand through this:))?

    Also, tips on spam reduction are welcome.

    Cordially,
    Jason Wallace
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you download SpamAssasson 3.2.5, go to the directory where you've downloaded it, and run

    Code:
    SPAMASSASSIN=Mail-SpamAssassin-3.2.5
    APPLICATION_NAME=ispconfig
    tar xvfz ${SPAMASSASSIN}.tar.gz
    cd ${SPAMASSASSIN}
    perl Makefile.PL PREFIX=/home/adm${APPLICATION_NAME}/${APPLICATION_NAME}/tools/spamassassin/usr SYSCONFDIR=/home/adm${APPLICATION_NAME}/${APPLICATION_NAME}/tools/spamassassin/etc
    make
    ?

    (Don't run make install!)

    IF you see no error, the upgrade should work without problems.
     
  3. jason.wallace

    jason.wallace New Member

    Here's what I got

    WHen I ran the "perl Makefile.PL...." line some "Note:"s were issued. For instance:
    optional module missing: Mail::SPF
    optional module missing: Mail::SPF::Query
    optional module missing: IP::Country
    optional module missing: Razor2
    optional module missing: Net::Ident
    optional module missing: IO::Socket::INET6
    optional module missing: IO::Socket::SSL
    optional module missing: Mail::DomainKeys
    optional module missing: Mail::DKIM
    optional module missing: Encode::Detect
    warning: some functionality may not be available,
    please read the above report before continuing!

    Checking if your kit is complete...
    Looks good
    Writing Makefile for Mail::SpamAssassin
    Makefile written by ExtUtils::MakeMaker 6.17

    make completed without any errors, as far as my understanding of its output allows.

    1. Next, Do I need to upgrade ISPConfig, or just do the make install now?

    2. Is there any benefit for me to upgrade ISPConfig since all I use it for is a quick way to add email addresses?

    Added: Do I need to do anything to sa-update since spamassassin is installed in an atypical directory or is running sa-update with no parameters enough?
     
    Last edited: Feb 5, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

     
  5. jason.wallace

    jason.wallace New Member

    Thank You! So far so good.

    I took the time to add the perl modules that spamassassin was grumbling about, re "make"ed it in a fresh folder and then did the make install.

    After a reboot, all seems well. Thanks falko for caring and helping me through this.

    Jason
     

Share This Page