Upgrading PHP from 5.4 to 5.6 on CentOS 6.8 (nginx)

Discussion in 'ISPConfig 3 Priority Support' started by inside83, Jun 11, 2016.

  1. inside83

    inside83 Member HowtoForge Supporter

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. inside83

    inside83 Member HowtoForge Supporter

    Ok, Till, I'll do that.
    So, following this tutorial, I should just replace '5.3.22' with '5.6.0' if I want PHP 5.6.0?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes. Please note that the version number is used in many paths as well, so one option ca be to copy the tutorial into word document and use the replace function to replace the version number.
     
  5. inside83

    inside83 Member HowtoForge Supporter

    Thank you Till!
    I copied to Word, replaced 'php-5.3.22' with php-5.6.22' (current stable) but when I get to .configure this error comes up:
    Code:
    configure: error: Cannot find imap library (libc-client.a). Please check your c-client installation.
    
    The same thing happened when I installed PHP 5.6 on Debian. I wrote about it here:
    https://www.howtoforge.com/communit...itional-php-version-on-debian-7-wheezy.73221/
    Could you please point me out in the right direction?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. inside83

    inside83 Member HowtoForge Supporter

    I tried but eventually i did it without
    --with-imap \
    --with-imap-ssl \
    Now, do I need to put 'fastcgi_pass 127.0.0.1:8999;' in nginx Directoves field?
    Any other configuration?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No, the ports get configured automatically, you don't have to set any directives. Just select the new php version in the website settings and press save button.
     
  9. inside83

    inside83 Member HowtoForge Supporter

    Is it possible to lose 'mail functionality' when changing PHP version?
    Mail account configured on ThunderBird work just fine but i get this in /var/log/maillog
    Code:
    Jul 18 13:50:19 vps postfix/submission/smtpd[31951]: connect from unknown[ip.of.the.server]
    Jul 18 13:50:19 vps postfix/submission/smtpd[31951]: SSL_accept error from unknown[ip.of.the.server]: 0
    Jul 18 13:50:19 vps postfix/submission/smtpd[31951]: warning: TLS library problem: 31951:error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:s3_pkt.c:1259:SSL alert number 48:
    Jul 18 13:50:19 vps postfix/submission/smtpd[31951]: lost connection after STARTTLS from unknown[ip.of.the.server]
    Jul 18 13:50:19 vps postfix/submission/smtpd[31951]: disconnect from unknown[ip.of.the.server]
    when checking mail configuration in eg OxWall.
    Is it due to me changing the PHP version or is it because of faulty mail server configuration?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't think that this is related to the PHP version change. seems to be a problem with the CA certificate (the SSL bundle, not the SSL cert itself) that is used in the postfix config.
     
  11. inside83

    inside83 Member HowtoForge Supporter

    How come that is not the issue when using ThunderBird?
    Could you, please, tell me how to resolve this or should I start a new thread and leave this one with 'Upgrading PHP from 5.4 to 5.6 on CentOS 6.8'?
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    I'm not the develper of Oxwall, so I can't tell you which problem this software has with the SSL configuration. Maybe you use a self signed ssl cert, which is fine for Thunderbird or you use a ssl cert authority that is known by thunderbird and not by oxwall.
     
  13. inside83

    inside83 Member HowtoForge Supporter

    I does not seam to be the issue with certificate since other websites on the same server do not send e-mails if I change it to PHP 5.6.22 from 'default'.
    It is definitely problem with PHP.
    Could you please help me track it down or (ideally) solve the problem?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Newer php versions do stricter ssl checks, so it might be that your web server requires an officially signed ssl cert from e.g. lets encrypt incl. intermediate ssl cert if you don't have an officially validated cert yet or you contact the devs of the oxwall software and ask them to disable the strict ssl check for the smtp connections or as third option, don't use ssl for the mail connection as you probably connect to localhost anyway so ssl is not necessary.
     
  15. inside83

    inside83 Member HowtoForge Supporter

    So, since oxwall probably won't hear me out, the solution is to disable SSL for mail?
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    That's probably the easiest solution to not use ssl for mail in oxwall.
     

Share This Page