upgrading php and mysql on ISPconfig 2.2.17 risk free?

Discussion in 'Installation/Configuration' started by mickeb, Jun 23, 2011.

  1. mickeb

    mickeb New Member


    ISPconfig is working fine, installed it on debian etch couple of years back without any update so far.

    Today, use PDO_MySQL and this requires php 5.3+.

    Right now i got:

    php 5.2.0-8 but need the latest php 5.3.6.

    Will i get some troubles by upgrading via apt-get?

    Second, is it good idea to make a overall upgrade on the system by apt-get? upgrade all exisiting packages? or will it result in a mess which force me maybe to reformat and reinstall debian + ispconfig?
  2. falko

    falko Super Moderator ISPConfig Developer

    AFAIK, there's no PHP 5.3.x for Etch via apt.

    Usually upgrade via apt-get work fine (make sure you use "etch" in /etc/apt/sources.list instead of "stable", because "squeeze" is the new "stable"), but to go sure you should create a backup before you do this.

Share This Page