Upgrading MySQL PHP on ISPConfig

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Aug 17, 2015.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good day once again,
    On a CentOS 6.7 box with latest ISPCOnfig, PHP 5.3 and MySQL 5.1.
    A customer has asked me to upgrade to PHP 5.6 and MySQL 5.6 for his latest WordPress installations.
    I understand there is a procedure on how to install different versions of PHP. I'll try this later.
    I spin up a test VPS (openVZ) with the clients setup (ploop template copy).

    ref:
    1st I tried this:
    https://www.rosehosting.com/blog/how-to-replace-mysql-with-mariadb-on-centos-6/
    2nd I tried this:
    http://dev.mysql.com/doc/mysql-repo-excerpt/5.6/en/updating-yum-repo.html
    http://dev.mysql.com/doc/mysql-repo...allation-yum-repo.html#yum-repo-select-series

    When I update with MariaDB 10.0 or MySQL 5.5. I get a white page when I go to https://<IP>:8080.
    MySQL6 is running, I check and my databases are still there...
    No harm done, working on a sandbox...

    1) What would be the proper way to upgrade MySQL ?
    2) If I were to reinstall the Perfect Server CentOS 6.7 with PHP 5.6 and MariaDB10.0, would the procedure work?

    Thanks,

    JP
     
  2. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Updating PHP
    I followed this tut:
    https://www.howtoforge.com/how-to-u...pm-and-fastcgi-with-ispconfig-3-centos-6.3-p4
    A) I'm having an issue with ./configure and --with-gd \ it seems to require a DIR
    (./configure --help
    --with-gd=DIR Include GD support. DIR is the GD library base)
    How could I find the base DIR for gd ?

    B) See error after > --with-zlib \ ?

    [[email protected] php-5.6.12]# ./configure \
    > --prefix=/opt/phpfcgi-5.6.12 \
    > --with-pdo-pgsql \
    > --with-zlib-dir \
    > --with-freetype-dir \
    > --enable-mbstring \
    > --with-libxml-dir=/usr \
    > --enable-soap \
    > --enable-calendar \
    > --with-curl \
    > --with-mcrypt \
    > --with-zlib \
    configure: WARNING: you should use --build, --host, --target
    configure: WARNING: invalid host type:
    checking for grep that handles long lines and -e... /bin/grep
    checking for egrep... /bin/grep -E
    checking for a sed that does not truncate output... /bin/sed
    checking build system type... config.sub: missing argument
    Try `config.sub --help' for more information.
    configure: error: /bin/sh ./config.sub failed
    [[email protected] php-5.6.12]# --with-gd \
    > --with-pgsql \
    > --disable-rpath \
    > --enable-inline-optimization \
    > --with-bz2 \
    > --with-zlib \
    > --enable-sockets \
    > --enable-sysvsem \
    > --enable-sysvshm \
    > --enable-pcntl \
    > --enable-mbregex \
    > --with-mhash \
    > --enable-zip \
    > --with-pcre-regex \
    > --with-mysql \
    > --with-pdo-mysql \
    > --with-mysqli \
    > --with-jpeg-dir=/usr \
    > --with-png-dir=/usr \
    > --enable-gd-native-ttf \
    > --with-openssl \
    > --with-fpm-user=apache \
    > --with-fpm-group=apache \
    > --with-libdir=lib64 \
    > --enable-ftp \
    > --with-imap \
    > --with-imap-ssl \
    > --with-kerberos \
    > --with-gettext \
    > --enable-cgi
    -bash: --with-gd: command not found

    Thanks,
    JP
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    You had a whitespce after one of the backslashes. A backslash just means to continue in the next line, so there might be no chars or a whitespace after the \

    Regarding gd, there is no path required, just ensure that the gd dev package is installed.
     
  4. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    PHP - I seem good with all of this...
    I installed gd-devel : yum install gd-devel (it was not in the list could) and removed the space. Got fastcgi 5.6 installed

    I tied to install php-fpm, I know I can ignore the message, but is the failed normal?

    [[email protected] opt]# /etc/init.d/php-5.6.12-fpm start
    Starting php-fpm [17-Aug-2015 20:30:23] WARNING: Nothing matches the include pattern '/opt/php-5.6.12/etc/pool.d/*.conf' from /opt/php-5.6.12/etc/php-fpm.conf at line 539.
    ................................... failed

    - netstat -nltp says it's running?
    tcp 0 0 127.0.0.1:8998 0.0.0.0:* LISTEN 9592/php-fpm
    - Site seems to answer well.

    MySQL
    What's the best way to upgrade MySQL from 5.1 to 5.6? I read that it's better to go from 5.1 to 5.2... to 5.6?
    Do you have a tut for upgrading MySQL and not breaking ISPConfig? Or upgrading to MariaDB 10.0 ?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats normal as there are no pools yet.

    I dont have any tutorials about mysql upgrades on centos.

    As far as I know, a direct update to 5.6should work.
     

Share This Page