Upgrading ISPConfig to - /etc/amavis/conf.d/50-user overwritten - postfix stopped

Discussion in 'Installation/Configuration' started by Aldo Giove, Apr 2, 2016.

  1. Aldo Giove

    Aldo Giove New Member

    Hi all, I am a very satisfied user of ISPConfig.
    Yesterday evening I did my first upgrade of ISPConfig after its original install, by running ispconfig_update.sh at root shell. Everything appeared to go fine, version was upgraded from to
    Unfortunately, the day after I was called by a number of users complaining that no email messages were received (i.e. via POP3 or IMAP or webmail connection to their own mailboxes, no new messages were received since yesterday). Obviously, they were sure that someone sent them some email.
    • Checked the mail queue: hundreds of emails were in queue waiting to be dispatched to the local mailboxes.
    • Checked /var/log/mail.warn, several messages like "amavis[2941]: (!)DENIED ACCESS from IP xxx.xxx.xxx.xxx, policy bank '' ", so I understood that something related to amavisd-new got wrong.
    • Extracted the previous version of all files in /etc (working the day before), compared with the current ones, I discovered that /etc/amavis/conf.d/50-user got overwritten exactly at the time of the upgrade of ISPConfig. The two following lines (added by me after install of ISPConfig) were missing:
      @inet_acl = qw( [::1] xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy );
      $inet_socket_bind = undef;
    • Re-added the two missing lines in 50-user, restarted amavisd and postfix, mail queue started again to be processed, now everything runs well.
    Is it normal that during upgrade process some customized files like /etc/amavis/conf.d/50-user get overwritten? Anyway, I changed a bit my configuration: instead of customizing /etc/amavis/conf.d/50-user, I created a new /etc/amavis/conf.d/51-user-customised containing only the two above lines, leaving /etc/amavis/conf.d/50-user untouched. I guess that this way next upgrade will be smoother.

    Kind regards
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that's intended. ISPConfig resets the fles to its defaults. Do not modify files that are managed by ispconfig manually and if you want to have a modified template, ensure to store them in conf-custom so that the updater can find and use them.

    Beside that, as stated in the release notes a reconfigure services was not necessary for the update from p8 to p9 so yu should have selected no for the reconfigure services questions and in that case, no config file would have been altered.
  3. Aldo Giove

    Aldo Giove New Member

    Dear Till, thank you for the answer. Actually I did the upgrade with not enough attention, it was better to answer NO to that question.
    Anyway now everything is working fine again.

    Thanks again

Share This Page