Upgrading from 2.2.8 to 2.2.18, just making sure everything first...

Discussion in 'Installation/Configuration' started by friday, Nov 23, 2007.

  1. friday

    friday Member

    I'm running ISPConfig at a client site who version is 2.2.8, running on top of Dapper Drake, 6.06.1.

    I think upgrading should be all set, but there is one thing I know I have to do.

    rm -f /bin/sh
    ln -s /bin/bash /bin/sh

    Besides the two commands above, anything else?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, changing the symlink is nescessary. Additionally, make sure that the following packages are installed:

    apt-get instal g++ cpp
  3. friday

    friday Member

    I couldn't wait. After running the commands above, the upgrade went without a hitch. It's properly updated.

    One question about Tesseract OCR (when adding it as part of the FuzzyOCR). It doesn't seem to be in the package repositories for 6.06.1. I attempted to downloaded from the Debian site. But, now it is complaining about dependecies. I'm assuming I can run the command apt-get upgrade to fix some of the versions of files needed by tesseract. But, the upgrade seems to want to upgrade a few of the integral packages used by ISPConfig. Is it safe to perform an upgrade via the apt-get get command and still keep an ISPConfig system running properly?

    Edit, looks like we posted at nearly the same time :). I did check to ensure g++ and cpp were installed. I ran into this back when I upgraded from 2.2.7 to 2.2.8, I think.
  4. falko

    falko Super Moderator ISPConfig Developer

    What packages exactly is it complaining about?
  5. friday

    friday Member

    From the text of the install routine

    tesseract-ocr depends on libc6 (>= 2.3.6-6); however:
    Version of libc6 on system is 2.3.6-0ubuntu20.
    tesseract-ocr depends on libgcc1 (>= 1:4.1.1-12); however:
    Version of libgcc1 on system is 1:4.0.3-1ubuntu5.
    tesseract-ocr depends on libstdc++6 (>= 4.1.1-12); however:
    Version of libstdc++6 on system is 4.0.3-1ubuntu5.

    The install also notes a dependency on tesseract-ocr-data, which I assume I can download and install via a dkpg -i command. I just want to make sure that ISPConfig runs, even if I upgrade on these packages required by tesseract-ocr.
    Last edited: Nov 26, 2007
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    It is not a good idea to mix up debian and ubuntu packages, this will mess up your apt database.
  7. friday

    friday Member

    I'll stick to your advice. The main thing is to keep the email server running and I do not wish to jeopardize anything on this live site.l

Share This Page