Upgraded to Ubuntu 12.04, ISPConfig 2 stopped working

Discussion in 'General' started by qqwong, May 25, 2012.

  1. qqwong

    qqwong New Member

    I've a server running Ubuntu 11.04 and ISPConfig 2. I upgraded the OS to Ubuntu 12.04 and the ISPConfig 2 stopped working. I then found out that ISPConfig 2 does not work with Ubuntu 12.04. What can I do to fix the server now? Can I install ISPConfig 3 on the same server and move the web site and user a/c + emails to ISPConfig 3? Please help!
  2. falko

    falko Super Moderator ISPConfig Developer

    You cannot upgrade from ISPConfig 2 to 3 because 3 is a total rewrite and not compatible with 2.

    So I guess there's nothing you can do to fix this...
  3. qqwong

    qqwong New Member

    Thanks Falko.

    I understand the ISPConfig 3 is a different system and cannot be upgraded from ISPConfig 2. My question is can I install ISPConfig 3 in the broken server and copy the web sites and emails to the proper locations for ISPConfig 3 to work?
    I do not have another server to install ISPConfig 3 afresh.

  4. falko

    falko Super Moderator ISPConfig Developer

    This will probably not work because ISPConfig 3 needs a different base setup than ISPConfig 2, therefore you need to install it on a fresh system.
  5. newfield_no1

    newfield_no1 New Member

    Ubuntu 12.04

    " I then found out that ISPConfig 2 does not work with Ubuntu 12.04"
    Is that correct?
    I have tryed that and it seams to work but not on a live server.
    I have moved from Ubuntu 8.04 to Ubuntu 12.04.
    Same version of ispconfig 2.2.37.
  6. newfield_no1

    newfield_no1 New Member


    It was not 12.04, it was 10.04 :-(
  7. falko

    falko Super Moderator ISPConfig Developer

    Ubuntu 10.04 works fine with ISPConfig, but I trongly recommend to use ISPConfig 3 because 2 is EOL.
  8. hahni

    hahni New Member

    And how can I reinstall ISPConfig 2 on a 12.04 LTS-System? I have same problem like entry poster!
  9. falko

    falko Super Moderator ISPConfig Developer

    No, ISPConfig 2 will not install on Ubuntu 12.04.
  10. hahni

    hahni New Member

    I know that, because the install stopped. Which workaround is possible to get install working on 12.04 LTS? For this server I need a workaround. Then I can transfer step by step to a new environment.
  11. falko

    falko Super Moderator ISPConfig Developer

    The only workaround I know is downgrading Ubuntu. :(
  12. hahni

    hahni New Member

    This is not a good news. I want to try it and it would be nice, if you could help me. In future i will use ISPConfig 3 for all other servers (like done for some ones). But this server must run with ISPConfig 2.

    I modified the "/etc/debian_issue" to the 10.04.4 LTS-values to start setup. But the setup crashes with this error:

    configure: error: Cannot find libmysqlclient under /usr.
    Note that the MySQL client library is not bundled anymore!
    ERROR: Could not configure PHP

    On 10.04 the library is here:

    On 12.04 it seems to be here:

    Maybe there must be another symlink?
  13. wrecked

    wrecked New Member

    work around

    Hi, I've run into this also.

    I've installed lib16 on ubuntu 12.04.
    and isp2 is working for me.

    for 32bit version:

    wget http://launchpadlibrarian.net/94563300/libmysqlclient16_5.1.58-1ubuntu5_i386.deb
    sudo dpkg -i libmysqlclient16_5.1.58-1ubuntu5_i386.deb
    for 64bit version:
    wget http://launchpadlibrarian.net/94808408/libmysqlclient16_5.1.58-1ubuntu5_amd64.deb
    sudo dpkg -i libmysqlclient16_5.1.58-1ubuntu5_amd64.deb
    Few years ago I've read that isp2 will coexist with isp3, as I did not have any issues with isp2, didn't know that isp2 is EOL.

    it's a terrible place to be in.
  14. hahni

    hahni New Member

    I have same opinion like you! Long time there was on homepage a hint, that both systems will be developed in future. Some time ago ISPConfig 2 was removed from homepage and now there is no help and support for users with ISPConfig 2. Its not ok. There is also no migration-tool for ISPConfig 3...

    With your trick you got ISPConfig 2 working on a 12.04 LTS-machine?
  15. wrecked

    wrecked New Member

    yes, working on 12.04 lts
  16. hahni

    hahni New Member

    Very great! And compiling Apache 1.3 from ISPConfig 2 setup is also no problem? Till and Falco told me, that this would be problem on Ubuntu 12.04 LTS...
  17. trondhuso

    trondhuso New Member


    It would be nice if someone who has moved from ISP2 to ISP3 can tell how they did this.

    I currently have a isp2 on a ubuntu804 that i'd love to upgrade/move to isp3 and ubuntu12.04+ (+ meaning upgrading without problems to latest LTS).

    I don't have many websites running on the isp2, but some... And one having close to 8gb of e-mails...

  18. hahni

    hahni New Member

    There is no import-tool for ISPConfig 3. Why you are not using 10.04 LTS like me with ISPConfig 2? It works fine! And with workaround above you can use it with 12.04 LTS too!
  19. hahni

    hahni New Member

    After your steps I always get this error:
    <=== src/modules/ssl
    <=== src/modules
    gcc -c -I./os/unix -I./include -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` modules.c
    gcc -c -I./os/unix -I./include -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` buildmark.c
    gcc -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I./lib/expat-lite `./apaci` -L/root/ispconfig/openssl/lib -rdynamic \
    -o httpd buildmark.o modules.o modules/standard/libstandard.a modules/ssl/libssl.a main/libmain.a ./os/unix/libos.a ap/libap.a regex/libregex.a lib/expat-lite/libexpat.a -lm -lcrypt -lssl -lcrypto -ldl
    make[2]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src'
    make[1]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    make[1]: Entering directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    ===> src/support
    make[2]: Entering directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    gcc -c -I../os/unix -I../include -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -I../lib/expat-lite `../apaci` htpasswd.c
    htpasswd.c:101:12: error: conflicting types for 'getline'
    /usr/include/stdio.h:675:20: note: previous declaration of 'getline' was here
    make[2]: *** [htpasswd.o] Error 1
    make[2]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    make[1]: *** [build-support] Error 1
    make[1]: Leaving directory `/tmp/install_ispconfig/compile_aps/apache_1.3.41'
    make: *** [build] Error 2
    ERROR: Could not make Apache

Share This Page