Upgraded to 14.04 LTS, E-mails Down

Discussion in 'Server Operation' started by N3RVE, May 7, 2014.

  1. N3RVE

    N3RVE New Member

    I decided to rebuild my Linode with the latest Ubuntu 14.04 LTS and setup everything from scratch.
    I followed this guide: http://www.howtoforge.com/perfect-s...hp-mysql-pureftpd-bind-dovecot-ispconfig-3-p4
    I'm not receiving e-mails and I'm not able to send any. After composing a mail using SquirrelMail 1.4.23 [SVN], I get an error: "ERROR: Message Not Sent. Server Replied:"

    I don't even know how to start diagnosing. Please, suggestions?
     
  2. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Test if the local mailsystem works, login to webmail with a account hosted on the server and send a email to the same address that you used to login to webmail. The email shall arrive within a minute back to your account when the local mailsystem works. If the email does not arrive, then check the mail.log as described below.

    Post the error message(s) that you get in the mail log file when the problem occurs. The mail log file is in the folder /var/log/, it is named "mail.log" on Debian and Ubuntu Linux
     
  3. N3RVE

    N3RVE New Member

    The local mail works, I think. I have webmin installed and it's set to e-mail automatic update notifications to an address created & hosted on the server. I receive these e-mails without issue. I tried to send myself an e-mail using SquirrelMail with no success. There's a 30 secs delay and I get the same error as if trying to send a mail out.

    I've uploaded my mail.log file, had to double-compress to get it uploaded.
    Thank you for your help.
     

    Attached Files:

  4. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Please post the master.cf file.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Login to webmail on your server, then send a email to the same address that you used for logging into webmail and post the messages that were added in the mail.log for this sending attempt.
     
  6. N3RVE

    N3RVE New Member

    Thank you. master.cf attached.
     

    Attached Files:

  7. N3RVE

    N3RVE New Member

    Code:
    May  9 12:38:32 research postfix/smtps/smtpd[22946]: connect from localhost[::1]
    May  9 12:39:01 research postfix/pickup[15715]: A227FE2B1: uid=0 from=<root>
    May  9 12:39:01 research postfix/cleanup[24171]: A227FE2B1: message-id=<20140509123901.A227FE2B1@research.n3rve.com>
    May  9 12:39:01 research postfix/qmgr[3657]: A227FE2B1: from=<root@research.n3rve.com>, size=118821, nrcpt=1 (queue active)
    May  9 12:39:09 research postfix/smtpd[25023]: connect from localhost[127.0.0.1]
    May  9 12:39:09 research postfix/smtpd[25023]: E3A47E266: client=localhost[127.0.0.1]
    May  9 12:39:09 research postfix/cleanup[24171]: E3A47E266: message-id=<20140509123901.A227FE2B1@research.n3rve.com>
    May  9 12:39:09 research postfix/smtpd[25023]: disconnect from localhost[127.0.0.1]
    May  9 12:39:09 research postfix/qmgr[3657]: E3A47E266: from=<root@research.n3rve.com>, size=119282, nrcpt=1 (queue active)
    May  9 12:39:09 research amavis[30498]: (30498-02) Passed CLEAN {RelayedInbound}, <root@research.n3rve.com> -> <root@research.n3rve.com>, Message-ID: <20140509123901.A227FE2B1@research.n3rve.com>, mail_id: psdrLzw79Wfm, Hits: 1.178, size: 118817, queued_as: E3A47E266, 8290 ms
    May  9 12:39:09 research postfix/smtp[24186]: A227FE2B1: to=<root@research.n3rve.com>, orig_to=<root>, relay=127.0.0.1[127.0.0.1]:10024, delay=8.3, delays=0.02/0.01/0/8.3, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as E3A47E266)
    May  9 12:39:09 research postfix/qmgr[3657]: A227FE2B1: removed
    May  9 12:39:09 research postfix/local[25026]: E3A47E266: to=<root@research.n3rve.com>, relay=local, delay=0.05, delays=0.04/0.01/0/0, dsn=2.0.0, status=sent (delivered to mailbox)
    May  9 12:39:09 research postfix/qmgr[3657]: E3A47E266: removed
    May  9 12:39:32 research postfix/smtps/smtpd[22946]: SSL_accept error from localhost[::1]: -1
    May  9 12:39:32 research postfix/smtps/smtpd[22946]: warning: TLS library problem: error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:628:
    May  9 12:39:32 research postfix/smtps/smtpd[22946]: lost connection after CONNECT from localhost[::1]
    May  9 12:39:32 research postfix/smtps/smtpd[22946]: disconnect from localhost[::1]
    May  9 12:39:51 research dovecot: imap-login: Login: user=<ralph@hrsystems.com.ng>, method=PLAIN, rip=41.206.1.9, lip=23.239.11.132, mpid=25031, TLS, session=<R+HW5Pb4XwApzgEJ>
    May  9 12:40:01 research postfix/smtps/smtpd[22946]: connect from localhost[::1]
    May  9 12:40:01 research postfix/smtps/smtpd[22946]: SSL_accept error from localhost[::1]: lost connection
    May  9 12:40:01 research postfix/smtps/smtpd[22946]: lost connection after CONNECT from localhost[::1]
    May  9 12:40:01 research postfix/smtps/smtpd[22946]: disconnect from localhost[::1]
    May  9 12:40:01 research dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<faBx5fb4dAAAAAAAAAAAAAAAAAAAAAAB>
    May  9 12:40:01 research dovecot: imap-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<Gctx5fb4UwAAAAAAAAAAAAAAAAAAAAAB>
    
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    remove the # in front of the submission and smtps lines in master.cf and restart postfix.
     
  9. N3RVE

    N3RVE New Member

    Thank you, till. The mail gets sent and I don't get the error in SquirrelMail anymore. However, the mail doesn't return to my inbox.
     
  10. N3RVE

    N3RVE New Member

    I still need help with this. I have just logged on to the server, wiped the mail.log file. I then signed into my e-mail account on the server and tried to e-mail myself. This is the result of the above (in mail.log):

    Code:
    May 10 16:45:01 research dovecot: imap-login: Disconnected (disconnected before auth was ready, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<kg5ybw753AAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:45:01 research postfix/smtpd[5095]: connect from localhost[::1]
    May 10 16:45:01 research postfix/smtpd[5095]: lost connection after CONNECT from localhost[::1]
    May 10 16:45:01 research postfix/smtpd[5095]: disconnect from localhost[::1]
    May 10 16:45:01 research dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<7Vpybw75/QAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:45:22 research dovecot: imap-login: Login: user=<n3rve@n3rve.com>, method=PLAIN, rip=::1, lip=::1, mpid=6041, secured, session=<hgWzcA753wAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:45:22 research dovecot: imap(n3rve@n3rve.com): Disconnected: Logged out in=44 out=843
    May 10 16:45:28 research dovecot: imap-login: Login: user=<n3rve@n3rve.com>, method=PLAIN, rip=::1, lip=::1, mpid=6043, secured, session=<ZfMLcQ754AAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:45:28 research dovecot: imap(n3rve@n3rve.com): Disconnected: Logged out in=261 out=1691
    May 10 16:45:46 research dovecot: imap-login: Login: user=<n3rve@n3rve.com>, method=PLAIN, rip=::1, lip=::1, mpid=6045, secured, session=<E3Accg754QAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:45:46 research dovecot: imap(n3rve@n3rve.com): Disconnected: Logged out in=79 out=777
    May 10 16:45:46 research dovecot: imap-login: Login: user=<n3rve@n3rve.com>, method=PLAIN, rip=::1, lip=::1, mpid=6047, secured, session=<WNcccg754gAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:45:46 research dovecot: imap(n3rve@n3rve.com): Disconnected: Logged out in=294 out=3065
    May 10 16:46:09 research postfix/smtpd[5095]: connect from localhost[::1]
    May 10 16:46:09 research postfix/smtpd[5095]: warning: table "mysql:/etc/postfix/mysql-virtual_client.cf": empty query string -- ignored
    May 10 16:46:09 research postfix/smtpd[5095]: 51818E2CE: client=localhost[::1]
    May 10 16:46:09 research postfix/cleanup[7067]: 51818E2CE: message-id=<5ffb5ecfaed9851d44fd54607418ebbd.squirrel@n3rve.com>
    May 10 16:46:09 research postfix/qmgr[26135]: 51818E2CE: from=<n3rve@n3rve.com>, size=698, nrcpt=1 (queue active)
    May 10 16:46:09 research postfix/qmgr[26135]: warning: connect to transport private/amavis: Connection refused
    May 10 16:46:09 research postfix/smtpd[5095]: disconnect from localhost[::1]
    May 10 16:46:09 research postfix/error[7068]: 51818E2CE: to=<n3rve@n3rve.com>, relay=none, delay=0.07, delays=0.05/0.01/0/0.01, dsn=4.3.0, status=deferred (mail transport unavailable)
    May 10 16:46:09 research dovecot: imap-login: Login: user=<n3rve@n3rve.com>, method=PLAIN, rip=::1, lip=::1, mpid=7071, secured, session=<Zrd+cw757AAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:46:09 research dovecot: imap(n3rve@n3rve.com): Disconnected: Logged out in=594 out=524
    May 10 16:46:09 research dovecot: imap-login: Login: user=<n3rve@n3rve.com>, method=PLAIN, rip=::1, lip=::1, mpid=7075, secured, session=<jpWHcw757gAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:46:09 research dovecot: imap(n3rve@n3rve.com): Disconnected: Logged out in=294 out=3065
    May 10 16:46:15 research dovecot: imap-login: Login: user=<n3rve@n3rve.com>, method=PLAIN, rip=::1, lip=::1, mpid=7077, secured, session=<P0Pfcw757wAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:46:15 research dovecot: imap(n3rve@n3rve.com): Disconnected: Logged out in=79 out=777
    May 10 16:46:17 research dovecot: imap-login: Login: user=<n3rve@n3rve.com>, method=PLAIN, rip=::1, lip=::1, mpid=7079, secured, session=<GyX1cw758AAAAAAAAAAAAAAAAAAAAAAB>
    May 10 16:46:17 research dovecot: imap(n3rve@n3rve.com): Disconnected: Logged out in=79 out=777
    
     
  11. N3RVE

    N3RVE New Member

    Any help, please? I'm still not able to receive mails.
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    amavis is not running. pleaserestart amavis.
     
  13. N3RVE

    N3RVE New Member

    --

    Logged in and sent myself an e-mail, still nothing. I should note that I receive e-mails from the system (webmin only).

    till, I'll be happy to send you root access details to take a look for yourself.
     
  14. N3RVE

    N3RVE New Member

    till, can I send you root access credentials via PM?
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    We do remote login support as part of our business support services only. You can reach the ISPConfig business support here:

    http://support.projektfarm.com/scp/

    For remote login support we charge 35 EUR / half hour (plus 19% VAT).
     
  16. N3RVE

    N3RVE New Member

    Thank you, till.
     
  17. bmurfin

    bmurfin New Member HowtoForge Supporter

    Mail not working after upgrade from Ubuntu 12.04 to 14.04

    I recently upgraded my server from ubuntu 12.04 to 14.04. Squirrelmail was working fine for all of the websites before the upgrade. Afterwards I updated ISPConfig 3 also. I can access my websites and everything is working except the mail. I can no longer access Squirrelmail for the virtual domains.

    I have checked the ISPConfig manual and forums but can't seem to find a solution to the problem. I would like to be able to preserve the existing mail so if I do need to completely reinstall Squirrelmail is there a way to backup existing mail boxes?

    Thanks for your help,

    Brian
     
  18. srijan

    srijan New Member HowtoForge Supporter

    What error you are getting when you are trying to access the webmail http:// yourIP/webmail?
    The error will be there in apache error.log
     
  19. bmurfin

    bmurfin New Member HowtoForge Supporter

    Squirrelmail not working after upgrade from Ubuntu 12.04 to 14.04

    This is the message from the error.log in /var/log/apache2

    [Tue Jul 15 05:02:51.925173 2014] [suexec:notice] [pid 2681] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jul 15 05:02:51.972732 2014] [auth_digest:notice] [pid 2683] AH01757: generating secret for digest authentication ...
    [Tue Jul 15 05:02:51.973758 2014] [:notice] [pid 2687] FastCGI: process manager initialized (pid 2687)
    [Tue Jul 15 05:02:52.052990 2014] [:notice] [pid 2683] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Tue Jul 15 05:02:52.053018 2014] [:notice] [pid 2683] mod_python: using mutex_directory /tmp
    [Tue Jul 15 05:02:52.064807 2014] [ssl:warn] [pid 2683] AH01906: RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Tue Jul 15 05:02:52.064834 2014] [ssl:warn] [pid 2683] AH01909: RSA certificate configured for billionbytes.com:8080 does NOT include an ID which matches the
    server name
     

Share This Page