Upgraded from Etch to Lenny

Discussion in 'General' started by jcombs_31, Oct 18, 2010.

  1. jcombs_31

    jcombs_31 New Member

    I'm having a few issues after I upgraded from Etch to Lenny.

    1. Squirrelmail (/webmail) says "No input file specified" when accessing that page. I went through and re-did squirrelmail-configure but same thing

    2. FTP - All accounts will no longer accept my passwords. I had to create the deb package again because I'm on openvz but cannot authenticate. Can't figure out why.

    3. rkhunter - Shows the following:

    The list of 2737 shows, then

    One thing to note when upgrading was that I chose not to change the config files associated with a number of packages in fear that it could break some ISPConfig functionality.

    Any hints on any of the above?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    1+2) Download the ispconfig tar.gz file and start the update.php script. Choose then to reconfigure services during update.

    3) most likely false positives. Update the rkhunter database with:

    rkhunter --update
    rkhunter --propupd
     
  3. jcombs_31

    jcombs_31 New Member

    Thanks Till, I did update to 3.0.3 after the lenny updates, so the services should have already been reconfigured.

    I had already done the rkhunter --update, but never ran the --propupd, so we'll see what happens.
     
  4. jcombs_31

    jcombs_31 New Member

  5. jcombs_31

    jcombs_31 New Member

    I've run the update scripts and still can't authenticate with any FTP user. Really doesn't make much sense to me.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Do you have any errors in your logs or in your FTP client? What's the output of
    Code:
    cat /proc/user_beancounters
    ?
     
  7. jcombs_31

    jcombs_31 New Member

    Haven't found any errors, here is the output of user_beancounters;

     
  8. falko

    falko Super Moderator ISPConfig Developer

    Looks ok.
    And there are no errors, not even in auth.log?
     
  9. jcombs_31

    jcombs_31 New Member

    Here is a snip from auth.log

     
  10. jcombs_31

    jcombs_31 New Member

    Here is a snip from auth.log

    seems like pure-ftpd cannot communicate correctly with mysql to get the user data
     

Share This Page