Upgraded apache2 to 2.4.34 for http2 and now facing some issues.

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Sep 15, 2018.

  1. pawan

    pawan Member HowtoForge Supporter

    after upgrade I am facing some issues like when I am trying to open phpmyadmin
    I am seeing lot of errors on the page such as
    Code:
    Deprecation Notice in ./../php/php-gettext/streams.php#48
    Methods with the same name as their class will not be constructors in a future version of PHP; StringReader has a deprecated constructor
    Code:
    Backtrace
    
    ./../php/php-gettext/gettext.inc#41: require()
    ./libraries/select_lang.lib.php#477: require_once(./../php/php-gettext/gettext.inc)
    ./libraries/common.inc.php#569: require(./libraries/select_lang.lib.php)
    ./index.php#12: require_once(./libraries/common.inc.php)
    is there a way I can fix this or I must downgrade the apache.
    The command I used for upgrade are like this:

    Code:
    sudo apt install software-properties-common
    sudo add-apt-repository ppa:ondrej/apache2
    sudo apt update
    sudo apt install apache2
    sudo a2enmod http2
    If you are using mod_php
    If you use mod_php module with Apache, then you are using prefork MPM module. Unfortunately Mod_http2 does not support prefork. You can use the event MPM module in order to support HTTP/2 and that requires you to run PHP with FastCGI because event MPM is not compatible with mod_php. Follow the steps below to switch from prefork to event MPM. Note that in the following commands php7.0 is used on Ubuntu 16.04 and PHP7.1 used on Ubuntu 17.10.

    Disable PHP7 module.
    sudo a2dismod php7.0
    Disable prefork MPM module.
    sudo a2dismod mpm_prefork
    Enable Event MPM, Fast_CGI and setenvif module.
    sudo a2enmod mpm_event proxy_fcgi setenvif

    Thanks
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Deprecation notices are no errors, they are just information for developers. When you see a backtrace, then there must be a fatal issue as well. My guess is that you did not just update apache, you probably updated PHP as well and the phpmyadmin version you use now is not compatible with that PHP version. Check if the PHP version is still the same and if not, try if you can enable the former PHP version again.
     

Share This Page