Upgrade Wiped All Data

Discussion in 'Installation/Configuration' started by wheatley81, Feb 22, 2007.

  1. wheatley81

    wheatley81 New Member

    I upgraded to .10 from .9 all went ok but when I came to log into ISPConfig in the browser I noticed all data had been removed.
    I had to log in as admin - admin which I had changed and also the accounts created under ISP Manager had been removed. I run the ISPConfig backups before the update but I am not sure if I can restore the accounts I had before from these, please can you tell me if this is possible?

    I have two zip files:

    All the emails accounts still work but I am unable to configure them through the browser now?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please make a backup from the current (damaged) database in case we need it later. Then replace the ISPConfig database with the latest backup you have.

    There had been one .sql file and two tar.gz files created in your /tmp/ folder, please copy these to a save place in case we need them to restore your system.

    Please post the output of:

    df -h

    Another question: Did you run the setup script twice?
  3. wheatley81

    wheatley81 New Member

    Forgive the stupid question but how do I go about replacing the database with the backup (newbie to Linux and ISPConfig)?

    Here is the output of df -h:
    Filesystem Size Used Avail Use% Mounted on
    /dev/hda1 108G 1.1G 101G 1% /
    varrun 506M 92K 506M 1% /var/run
    varlock 506M 0 506M 0% /var/lock
    procbususb 10M 104K 9.9M 2% /proc/bus/usb
    udev 10M 104K 9.9M 2% /dev
    devshm 506M 0 506M 0% /dev/shm

    I only ran the setup once!
  4. wheatley81

    wheatley81 New Member

    I decided to uninstall and re-install ISPConfig as I did not have much to loose. After the install I tried to log in using admin - admin but no luck so I tried the old password and it worked :confused: and now all my settings (emails, clients, etc) are back.

Share This Page