Upgrade to PHP 5.2.4 in Debian Etch + ISPConfig 2.2.18?

Discussion in 'Installation/Configuration' started by jtwyrrpirate, Oct 31, 2007.

  1. jtwyrrpirate

    jtwyrrpirate New Member

    I need to upgrade from PHP 5.2.0-8 to 5.2.4 on a Debian Etch box running ISPConfg 2.2.18, for security reasons. I have tried several methods but I haven't had much luck (including compiling PHP from source and installing the PHP 5.2.4 package in Debian's unstable repo). Can anyone offer some insight into how this upgrade might be accomplished? Any insight would be greatly appreciated.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am sure that there is no security problem in the debian php version, so no need to update. Version 5.2.0-8 means PHP 5.2.0 plus 8 patch levels. The Debian devs are patching old versions to make sure that there are no security problems to keep the system secure and compatible instead of using 5.2.4.
  3. jtwyrrpirate

    jtwyrrpirate New Member


    That's what I thought, but the machine is getting flagged by Nessus scans, so I thought it might be good to upgrade. Thanks again for the info.

Share This Page