Upgrade to latest relase stopped everything working

Discussion in 'General' started by ColinMussett, Jul 22, 2017.

  1. ColinMussett

    ColinMussett New Member

    Just upgraded and now when browsing to the admin page I get the error
    Warning: Declaration of db::query($sQuery = '') should be compatible with mysqli::query($query, $resultmode = NULL) in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 0
    i can login, but any sub functions are not working, just get the small spinning ball.
    Any help, suggestions please ...
    Colin
     
  2. sjau

    sjau Local Meanie Moderator

    Where did you upgrade from?
     
  3. ColinMussett

    ColinMussett New Member

    stable release, ispconfig_upgrade.sh
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the browser cache and cookies.
     
  5. ColinMussett

    ColinMussett New Member

    done even tried different browsers, still no luck, no errors that I can find in the log files on the server, not even the message that's displayed when I connect to the server.
     
  6. unglaublich

    unglaublich New Member

    Got the same problem after updating PHP7.1...
    I manually set /usr/bin/php to /usr/bin/php5.6 in server.sh to solve the problem temporarily.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    PHP 7.1 is not supported. You may use it for websites but not for ISPConfig itself. Supported are PHP version between 5.3.x and 7.0.x
     
    ahrasis likes this.
  8. unglaublich

    unglaublich New Member

    Thanks for your reply Till,
    After an upgrade, /usr/bin/php is now 7.1 and server.sh refers to /usr/bin/php.
    Should I symlink /usr/bin/php to php70?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, please try that.
     
  10. ahrasis

    ahrasis Well-Known Member

    I create an issue in relation to Warning: Declaration of db::query($sQuery = '') should be compatible with mysqli::query($query, $resultmode = NULL) with a suggested fix in ISPC git.
     
  11. chaosad

    chaosad New Member

    Hello, is there a PHP 7 deadline planned for ispconfig panel?
    I tried it today with PHP 7.3 but it didnt work and I dont want to start another thread for this.
    thank you
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    You are posting here to a very outdated and old thread, so nothing posted above applies to any recent ISPConfig version.

    As a general note:

    ISPConfig uses and requires the PHP version that ships with the operating system version that you use (Ubuntu 18.04 = PHP 7.2, Debian 9 = PHP 7.0). Older and newer versions incl. PHP 7.3 can be used as additional PHP versions in ISPConfig. ISPconfig fully supports PHP 7.3, but there is no operating system that is supported by ISPconfig which ships with PHP 7.3 as base PHP version, so there can't be any setups that use PHP 7.3 as base PHP yet.

    Please follow the perfect server guides listed here to install your server:

    https://www.ispconfig.org/documentation/

    They ensure that the proper PHP version gets installed on your server.
     
    Last edited: Mar 8, 2019
    chaosad likes this.

Share This Page