Upgrade to 3.2 error

Discussion in 'Installation/Configuration' started by drapsag, Oct 23, 2020.

  1. drapsag

    drapsag New Member

    I have a multi server setup with one master and two slaves. The master is running Stretch, fully updated. I upgraded from 3.1.15 to 3.2 and now ISPConfig doesn't work. The upgrade went fine - no errors on all three server but I get an Internal Server error when I go to the panel web site and when I tail the apache2/error.log I see the following:
    ----
    [Fri Oct 23 14:53:20.550802 2020] [core:notice] [pid 15119] AH00094: Command line: '/usr/sbin/apache2'
    .php-fcgi-starter: line 6: /usr/bin/php-cgi7.0: No such file or directory
    [Fri Oct 23 14:53:42.051002 2020] [fcgid:warn] [pid 15201] (104)Connection reset by peer: [client xx.xx.xx.xx:59904] mod_fcgid: error reading data from FastCGI server
    [Fri Oct 23 14:53:42.051057 2020] [core:error] [pid 15201] [client xx.xx.xx.xx:59904] End of script output before headers: index.php
    -----
    The panel had been working immediately before the upgrade. All the web sites and other services that the master hosts are working fine.
    Thanks in advance.
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Do you have any conf-custom templates? If so rename or update them and reconfigure services with the updater again. If not, I don't know what it is right offhand; what's in your .php-fcgi-starter file? Are your php daemons running?
     
  3. drapsag

    drapsag New Member

     
  4. drapsag

    drapsag New Member

    I figured out that somehow in the many upgrades of that server from Squeeze to Stretch, PHP7.0 was never installed. I am using additional PHP versions for my customer web sites, but the default PHP version on the server itself was 5.old. Once I installed 7, and reran the upgrade, everything works as expected.
     
    Th0m likes this.
  5. Aldo Giove

    Aldo Giove New Member

    Hi, I am in the same trouble, with a difference: I already had PHP 5.6 and 7.0 installed. phpinfo() report PHP 5.6 running. I tried to switch to 7.0 with a2enmod php7.0; it apparently succeeded but phpinfo() keeps using PHP 5.6. And I still get 500 Internal Server Error when invoking ISPConfig.
    Tried also to uninstall and reinstall libapache-mod-php7.0 and libapache-mod-php but no luck.
    The only test I can still do is to totally remove PHP5.6 but this scares me a bit, since some package appear to require it (squirrelmail) and moreover I read somewhere that it's not advisable to remove it.

    I'm totally stuck.

    Suggestions?
    Thanks
    Aldo
     
  6. Aldo Giove

    Aldo Giove New Member

    OK solved now. the package php7.0-cgi for some unknown reason was missing. I installed it manually and now ISPconfig panel works again.

    Bye
    Aldo
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I assume @Aldo Giove is using Debian like drapsag.
    On Debian and Ubuntu (at least, do not know about other LInux distributions) the most recently installed PHP version becomes the system default PHP. Thus all applications that use PHP should then use that version, unless they do something that allows them to use a specific PHP version.
    The system default PHP can be altered using commands
    Code:
    update-alternatives --config php
    update-alternatives --config php-cgi
    After dist-upgrade of Debian or Ubuntu checking what the system default PHP is and installing another or setting the default to the desired version may be needed.
     
    Aldo Giove likes this.
  8. Aldo Giove

    Aldo Giove New Member

    Thank you for your answer.
    Yes, I'm using Debian, sorry for not saying that.
    I already tried the "update-alternatives" things with no success (php7 was already the default in command-line scenarios), as well as the mentioned "a2enmod"s.

    The issue was solved by installing the missing package php7.0-cgi.

    Best regards
    Aldo
     

Share This Page