Upgrade to 3.2.1 : "Send a copy to:" option does not work

Discussion in 'Installation/Configuration' started by sp4148, Nov 27, 2020.

  1. sp4148

    sp4148 New Member

    After upgrading ISPconfig from ISPConfig-3.1.15 to ISPConfig 3.2.1, the "Send a copy to:" and "Send outgoing BCC to:" options does not work.No error messages in the mail.log.

    Centos 7.9
    Reconfigure Services? (yes, no, selected) [no]:yes
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. sp4148

    sp4148 New Member

    thanks for your reply,but no this issue
    I already updated to 3.2.1, the tls problem should already be fixed in this version
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    - Did you reconfigure services when updating?
    - Is Postfix up to date?
    - Have you tried removing the value that's set, saving, and then setting it again?
     
  5. sp4148

    sp4148 New Member

    - Did you reconfigure services when updating?
    Reconfigure Services? (yes, no, selected) [no]:yes
    - Is Postfix up to date?
    I just update centos to later version 7.9
    postfix-2.10.1-9.el7.x86_64
    - Have you tried removing the value that's set, saving, and then setting it again?
    I try many time ,restore 3.1.15,then update to 3.2/3.2.1 ,also same issue
     
  6. sp4148

    sp4148 New Member

    for maillog I try send many time and only got once orig_to, buy also cannot received the mail.
    Nov 26 16:17:32 mail postfix/smtp[13990]: EAB8781C7: to=<[email protected]>, orig_to=<[email protected]>, relay=mx-server[3.2.2.2]:25, delay=12, delays=0.01/0.02/11/0.18, dsn=2.1.5, status=deliverable (250 2.1.5 Ok)
     
  7. sp4148

    sp4148 New Member

    then I try to copy ispconfig 3.1.15 mysql-virtual_email2email.cf to ispconfig 3.2.1 /etc/postfix folder
    also no help.
     
  8. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Latest postfix version is 3.4.14. Can you try updating and see if it works with the newest version?
     
  9. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Also check if you have any old conf-custom templates (a common cause of upgrade failures).
     
    Th0m likes this.
  10. sp4148

    sp4148 New Member

    today I fresh install a centos 8.2 VM with postfix-3.3.1-12.el8.x86_64, and install ispconfig 3.2.1
    same results,
    then I upgrade the postfix to 3.5 (postfix3-2:3.5.6-1.gf.el8.x86_64)
    "Send a copy to:" also no work.
    Buy I found if I send mail from same server then the "Send a copy to:" will work
    If mail from outside server then the function cannot work
     
  11. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Do you have the Copy during Delivery setting enabled? Does the mailbox itself get a copy, only the forward does not work?

    Send a new test email with your current system and paste ask the logs that you get from that.
     
  12. sp4148

    sp4148 New Member

    I had testing this before
    If I enable "Copy during delivery"
    I will got the copy
     
  13. sp4148

    sp4148 New Member

    when I new created a email account ,system will send a welcome message with orig_to ,but other side no receive any message.
    this orig_to for the first mail only
    ---
    Nov 28 17:10:01 mail postfix/pickup[24167]: 4Cjm0n6FcrzB31f0: uid=0 from=<root>
    Nov 28 17:10:01 mail postfix/cleanup[24484]: 4Cjm0n6FcrzB31f0: message-id=<[email protected]>
    Nov 28 17:10:01 mail postfix/qmgr[24168]: 4Cjm0n6FcrzB31f0: from=<[email protected]>, size=635, nrcpt=1 (queue active)
    Nov 28 17:10:02 mail postfix/postscreen[24542]: CONNECT from [::1]:43104 to [::1]:25
    Nov 28 17:10:02 mail postfix/postscreen[24542]: WHITELISTED [::1]:43104
    Nov 28 17:10:02 mail postfix/smtpd[24549]: connect from localhost[::1]
    Nov 28 17:10:02 mail postfix/smtpd[24549]: lost connection after CONNECT from localhost[::1]
    Nov 28 17:10:02 mail postfix/smtpd[24549]: disconnect from localhost[::1] commands=0/0
    Nov 28 17:10:02 mail postfix/smtpd[24558]: connect from localhost[127.0.0.1]
    Nov 28 17:10:02 mail postfix/smtpd[24558]: 4Cjm0p54YHzB31f1: client=localhost[127.0.0.1]
    Nov 28 17:10:02 mail postfix/cleanup[24484]: 4Cjm0p54YHzB31f1: message-id=<[email protected]>
    Nov 28 17:10:02 mail postfix/smtpd[24558]: disconnect from localhost[127.0.0.1] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
    Nov 28 17:10:02 mail postfix/qmgr[24168]: 4Cjm0p54YHzB31f1: from=<[email protected]>, size=1373, nrcpt=2 (queue active)
    Nov 28 17:10:02 mail postfix/amavis/smtp[24497]: 4Cjm0n6FcrzB31f0: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10026, delay=0.93, delays=0.09/0.05/0.02/0.77, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10027): 250 2.0.0 Ok: queued as 4Cjm0p54YHzB31f1)
    Nov 28 17:10:02 mail postfix/qmgr[24168]: 4Cjm0n6FcrzB31f0: removed
    Nov 28 17:10:02 mail postfix/lmtp[24559]: 4Cjm0p54YHzB31f1: to=<[email protected]>, relay=mail.xxx.com[private/dovecot-lmtp], delay=0.18, delays=0.03/0.04/0.02/0.09, dsn=2.0.0, status=sent (250 2.0.0 <[email protected]> qNBBL+oTwl/xXwAAj0IT1A Saved)
    Nov 28 17:10:02 mail postfix/smtp[24560]: Untrusted TLS connection established to mx1.xxx.net[2.2.2.2]:25: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
    Nov 28 17:10:03 mail postfix/smtp[24560]: 4Cjm0p54YHzB31f1: to=<[email protected]>, orig_to=<[email protected]>, relay=mx1.cc.net[2.2.2.2]:25, delay=0.46, delays=0.03/0.04/0.22/0.17, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as BC50F20F4C92)
    Nov 28 17:10:03 mail postfix/qmgr[24168]: 4Cjm0p54YHzB31f1: removed
    ---
     
  14. sp4148

    sp4148 New Member

    after first mail, all mail as below:
    ----
    Nov 28 17:19:01 mail postfix/postscreen[25321]: CONNECT from [209.85.167.49]:35454 to [2.2.2.2]:25
    Nov 28 17:19:07 mail postfix/postscreen[25321]: PASS NEW [209.85.167.49]:35454
    Nov 28 17:19:08 mail postfix/smtpd[25341]: connect from mail-lf1-f49.google.com[209.85.167.49]
    Nov 28 17:19:09 mail postfix/smtpd[25341]: Anonymous TLS connection established from mail-lf1-f49.google.com[209.85.167.49]: TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256 bits)
    Nov 28 17:19:09 mail postfix/smtpd[25341]: NOQUEUE: filter: RCPT from mail-lf1-f49.google.com[209.85.167.49]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10026; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-lf1-f49.google.com>
    Nov 28 17:19:09 mail postfix/smtpd[25341]: NOQUEUE: filter: RCPT from mail-lf1-f49.google.com[209.85.167.49]: <[email protected]>: Sender address triggers FILTER amavis:[127.0.0.1]:10024; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-lf1-f49.google.com>
    Nov 28 17:19:10 mail postfix/smtpd[25341]: 4CjmCL0g57zB31f0: client=mail-lf1-f49.google.com[209.85.167.49]
    Nov 28 17:19:10 mail postfix/cleanup[25353]: 4CjmCL0g57zB31f0: message-id=<[email protected]om>
    Nov 28 17:19:10 mail postfix/qmgr[24168]: 4CjmCL0g57zB31f0: from=<[email protected]>, size=2523, nrcpt=1 (queue active)
    Nov 28 17:19:10 mail postfix/smtpd[25341]: disconnect from mail-lf1-f49.google.com[209.85.167.49] ehlo=2 starttls=1 mail=1 rcpt=1 data=1 quit=1 commands=7
    Nov 28 17:19:11 mail postfix/10025/smtpd[25357]: connect from localhost[127.0.0.1]
    Nov 28 17:19:11 mail postfix/10025/smtpd[25357]: 4CjmCM32rpzB31f1: client=localhost[127.0.0.1]
    Nov 28 17:19:11 mail postfix/cleanup[25353]: 4CjmCM32rpzB31f1: message-id=<[email protected]om>
    Nov 28 17:19:11 mail postfix/10025/smtpd[25357]: disconnect from localhost[127.0.0.1] ehlo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
    Nov 28 17:19:11 mail postfix/qmgr[24168]: 4CjmCM32rpzB31f1: from=<[email protected]>, size=3124, nrcpt=1 (queue active)
    Nov 28 17:19:11 mail postfix/smtp[25355]: 4CjmCL0g57zB31f0: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=1.5, delays=0.62/0.04/0.01/0.86, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 4CjmCM32rpzB31f1)
    Nov 28 17:19:11 mail postfix/qmgr[24168]: 4CjmCL0g57zB31f0: removed
    Nov 28 17:19:11 mail postfix/lmtp[25358]: 4CjmCM32rpzB31f1: to=<[email protected]>, relay=mail.xxx.com[private/dovecot-lmtp], delay=0.09, delays=0.01/0.04/0.02/0.02, dsn=2.0.0, status=sent (250 2.0.0 <[email protected]> kj8UHQ8Wwl8PYwAAj0IT1A Saved)
    Nov 28 17:19:11 mail postfix/qmgr[24168]: 4CjmCM32rpzB31f1: removed
     
  15. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    That is the copy being made and sent, check your logs for what happened with queue id BC50F20F4C92.

    I note you have postscreen running on port 25, you should not use that for mail submission, either send on one of the submission ports (465 or 587) and/or don't use postscreen on localhost, just your public addresses.
     
  16. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    After the base ispconfig install, did you test the copy, before making further changes like adding postscreen? That could be where the problem came in, as the copies work on my systems; though I don't run centos, so maybe there's a difference in the template or installer for centos.

    Can you put your full main.cf and master.cf?
     
  17. sp4148

    sp4148 New Member

    -
    I try disabled postscreen and restart postfix also same results, no help
     
  18. sp4148

    sp4148 New Member

    attached
     

    Attached Files:

  19. sp4148

    sp4148 New Member

    below for my update from 3.15 to 3.2.1 whit one warning message

    Reconfigure Services? (yes,no,selected) [yes]:

    Configuring Postfix
    Configuring Dovecot
    Configuring Spamassassin
    Configuring Amavisd
    Configuring Getmail
    Configuring Database
    Updating ISPConfig
    PHP Warning: symlink(): No such file or directory in /root/ispconfig3_install/install/lib/installer_base.lib.php on line 2792
    Certificate exists. Not creating a new one.
    Reconfigure Crontab? (yes,no) [yes]:

    Updating Crontab
    no crontab for getmail
    Restarting services ...
    Update finished.
     
  20. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    While I don't have a centos box to compare to, you seem to have a very customized postfix config, saying you made a "fresh install" and have the problem is quite misleading.

    Your issue is likely coming from the receive_override_options you set in 127.0.0.1:10025, it should not have no_address_mappings. That's why local email (which is reinjected from amavis on port 10027) works, but external mail (reinjected on 10025) fails, the port 10027 has the correct receive_override_options setting.

    In a default setup the "send copy to" would happen in virtual_alias_maps via mysql-virtual_email2email.cf; you might ensure your /etc/postfix/mysql-virtual_email2email.cf is the default and also test what you get when querying it (postmap -q [email protected] mysql:/etc/postfix/mysql-virtual_email2email.cf). It's probably fine if your internal copy was delivered, but worth verifying.

    If the above doesn't fix the problem, try going back to a default config and introduce your changes one piece at a time, then you'll know where to look when it breaks. You can always post back for assistance if you need help, but it'll be less to try to sort through.
     

Share This Page