Upgrade to 3.2.1: Email Domain Aliases not working

Discussion in 'Installation/Configuration' started by customhost, Nov 27, 2020.

  1. customhost

    customhost New Member

    Hi all,
    after the upgrade to 3.2.1 all of my email domain aliases stopped working. For each of them, I receive the following error when trying to send to a domain alias internally (from the server I run ISPConfig):
    Code:
    <[email protected]>: mail for DOMAIN.COM loops back to myself
    When trying to send from external mail servers, I get the following:
    Code:
    554 5.7.1 <[email protected]>: Relay access denied
    I needed to replace the email domain aliases with Catchall entries to get my emails back working.
    Any suggestions why I can't use email domain aliases anymore after the upgrade?
    Many thanks in advance.
     
    Last edited: Nov 27, 2020
  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Works fine here. Did you reconfigure services when upgrading?
     
  3. customhost

    customhost New Member

    Yes, I did. Also compared postfix main.cf and master.cf with the pre-upgrade versions and also restored them but still, the emails were not delivered.
    I'm using Postfix version 3.1.15.
     
  4. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Try running the update again and reconfigure services. Don't put back the old config as this will break several things.
    Code:
    ispconfig_update.sh --force
     
    electronico_nc and customhost like this.
  5. customhost

    customhost New Member

    Thank you! That did the trick.
    As the updater told me that I was using some (very old) conf-custom templates which were the cause of this issue.
     
    electronico_nc and Th0m like this.
  6. Hello,
    Same issue there, had to replace custom files :
    Thanks !
     
    Th0m likes this.
  7. nhybgtvfr

    nhybgtvfr Active Member

    was just seeing the same issue with mailforwards and the mailbox 'send copy to' option, it may also have affected domain aliases on my system, but didn't have any i could test.
    had just updated from 3.1.15p3 on ubuntu 18.04 to 3.2 and then 3.2.1, still on 18.04.
    mailforwards and send copy to both returning 5.7.1 relay access denied messages to the sender.
    there were no custom-configs on any system (multi-server system with dedicated email server)

    tried restarting postfix again, rechecked main.cf and master.cf against backup copies, nothing i could see that would obviously cause issue. the full cipherlist i've seen mentioned in an other thread for mailforward problems on 3.2 was already in the postfix config.

    ran ispconfig_update.sh --force as suggested here (force updated to stable), not expecting it to make any difference. but now mailforwards and 'send copy to' are both working. :)


    just posting it here in case anyone else runs into it as well.
     

Share This Page