upgrade to 2.2.21 says no gcc

Discussion in 'Installation/Configuration' started by Appie Thrasher, Mar 16, 2008.

  1. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    I am trying to upgrade my ispconfig to the latest version.
    If I launch the setup its halted after the license text.
    I get this error
    Code:
    ./setup2: line 709: which: command not found
    ERROR: gcc not found!
    
    If I do the apt-get gcc it says already latest version installed?

    I have red the 2.2.19 thread about the problems with clamav but that Is not the solution for my problem (tried it).

    The thing is now I cant login anymore to my ispconfig. My site's are still working
    luckily.

    Is there an easy way to get things working again?

    TIA
     
  2. jnsc

    jnsc rotaredoM Moderator

    Code:
    apt-get install which
     
  3. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    gues you mean
    Code:
    apt-get install gcc
    If I do that I get the message that the newest version already is installed.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This thread is for 2.2.19 and does not apply to 2.2.21 as the problem is fiixed since 2.2.20.

    Please make sure that you have the c++ compiler installed too:

    apt-get instal gcc cpp g++

    Before you try to update ispconfig again, always run the command:

    mkdir /root/ispconfig

    to ensure that ISPConfig starts in update mode again.
     
  5. jnsc

    jnsc rotaredoM Moderator

    No, I really mean

    Code:
    apt-get install which
    As your error is
    Code:
    which: command not found
     
  6. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    If I do this I get the message saying that the ones I have are the latest.

    I get
    Code:
    [email protected]:~# mkdir /root/ispconfig
    mkdir: cannot create directory `/root/ispconfig': File exists
    
    So all is there but it's not updating??
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    apt-get install which

    as jnsc requested and then try again.
     
  8. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Then I get this in dutch
    Code:
    [email protected]:~# apt-get install which
    Pakketlijsten worden ingelezen... Klaar
    Boom van vereisten wordt opgebouwd
    Reading state information... Klaar
    E: Kon pakket which niet vinden
    
    Roughly translated: reading the packages, reading state information e:could not find package.

    I think its looking on my cd-rom for the pacage but if i check the sources.list i commented out the cd-rom. Is it possible that the install has put an other sources.list somewhere on my server and is using that one??
     
  9. falko

    falko Super Moderator ISPConfig Developer

    The package containing which is named debianutils:

    Code:
    apt-get install debianutils
     
  10. jnsc

    jnsc rotaredoM Moderator

    Try out this :
    Code:
    apt-get update
    apt-get install debianutils
    after this try :
    Code:
    which gcc
     
  11. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    If I do
    I get again the message that the latest version is installed.

    Even if I do the update and upgrade as jnsc says I get the message newest version is already installed.

    Is there more I can do?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    updatedb
    locate which
    and
    Code:
    env
    ?
     
  13. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    Falko,

    First thanks for the time you take on this holliday,
    here I go


    Code:
    [email protected]:~# updatedb
    [email protected]:~# locate which
    /usr/bin/which
    /usr/lib/python2.4/whichdb.py
    /usr/lib/python2.4/whichdb.pyc
    /usr/share/man/fr/man1/which.1.gz
    /usr/share/man/man1/which.1.gz
    
    And
    Code:
    TERM=xterm
    SHELL=/bin/bash
    SSH_CLIENT=192.168.1.2 49553 22
    SSH_TTY=/dev/pts/0
    USER=root
    LS_COLORS=no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.flac=01;35:*.mp3=01;35:*.mpc=01;35:*.ogg=01;35:*.wav=01;35:
    MAIL=/var/mail/root
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
    PWD=/root
    LANG=nl_NL.UTF-8
    SHLVL=1
    HOME=/root
    LOGNAME=root
    SSH_CONNECTION=192.168.1.2 49553 192.168.1.100 22
    LESSOPEN=| /usr/bin/lesspipe %s
    LESSCLOSE=/usr/bin/lesspipe %s %s
    _=/usr/bin/env
    
     
  14. falko

    falko Super Moderator ISPConfig Developer

    Everything's looking as it should, and which is installed.
    Please run
    Code:
    which which
    again (as root user). It should display /usr/bin/which.
     
  15. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    If i run
    Code:
    [email protected]:~# which which
    
    I am getting this
    Code:
    [email protected]:~# which which
    -bash: which: command not found
    [email protected]:~#
    
    Is it an ide to uninstall ISPConfif and reinstall again? I red somewhere on the forum that with an uninstall the settings and acounts are not gone.
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Did you log in as root directly, or as another user first and use su?
     
  17. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    I am logging in as root with winscp and than open an putty session also as root.
     
  18. falko

    falko Super Moderator ISPConfig Developer

    That's really strange... :confused:
     
  19. Appie Thrasher

    Appie Thrasher Member HowtoForge Supporter

    I am working already to install a second server so I can format the one I have.
    It would be easier to have access to my server so I could see how I did things a year ago.

    Gues I have to start realy from scratch again this time. I must write down the things I am going to do.

    And next time before I am going to upgrade ISPconfig make an disk image.

    BTW THANKS very much for trying to help me out...
     

Share This Page