upgrade PHP 7.2 ispconfig not work

Discussion in 'Installation/Configuration' started by yatoula, Mar 28, 2020.

  1. yatoula

    yatoula New Member

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The default version of an OS should not be changed, it is to be expected that applications which rely on the default PHP of the OS will start to fail if you change it, if you want to have a higher default version, upgrade the OS. Rollback your setup so that it uses the PHP 7.0 as default again and then install additional PHP versions as described here for the websites: https://www.howtoforge.com/tutorial...fig-3-from-debian-packages-on-debian-8-and-9/
     
  3. yatoula

    yatoula New Member

    Thanks but when i want to install php 7.4 i have this message ..
    E: Unable to find the libonig5 package
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    This package exists on Debian stable only, so it might be that you have to upgrade from Debian 9 to Debian 10 when you want to install PHP 7.4.
     
    yatoula likes this.
  6. yatoula

    yatoula New Member

    Ok thanks. I'm a novice and i learn..;)

    Now y have another problem for install ioncube. Because i look this post :
    https://www.howtoforge.com/tutorial/install-ioncube-loader-on-debian-9/
    in this line :
    cd ioncube
    cp ioncube_loader_lin_7.0.so /usr/lib/php/20151012/
    Next, you will need to edit php.ini file and add path of the ioncube extension. You can do this with the following command:

    sudo nano /etc/php/7.0/apache2/php.ini
    Add the following line:

    zend_extension=/usr/lib/php/20151012/ioncube_loader_lin_7.0.so

    Save the file, then open other php.ini file:

    sudo nano /etc/php/7.0/cli/php.ini
    Add the following line:

    zend_extension=/usr/lib/php/20151012/ioncube_loader_lin_7.0.so

    Save and close the file, then restart Apache service to apply the changes:


    I change 7.0 by 7.2 because i have install php 7.2 but where i put this line ?
    zend_extension=/usr/lib/php/20151012/ioncube_loader_lin_7.2.so
     
  7. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    /etc/php/7.2/cli/php.ini maybe?
    But what about your original problem, does ISPConfig work now?
    What is default PHP version now?
     
  8. yatoula

    yatoula New Member

    thanks, i put in /etc/php/7.2/cli/php.ini
    and i restart service and now it's good.. Thanks
     
  9. yatoula

    yatoula New Member

    pff i have another problem now. After i install softaculous and i have a problem with soap. Look the message :
    Hi,
    The Soap extension was not installed on your server, I have installed and enabled the soap extension and then reinstalled Softaculous on your server.

    The Softaculous is working fine now, however the images are not being loaded properly, it seems there is some firewall restriction or extension on your server which is not allowing to load the images from our mirror servers.

    Please whitelist all the mirror server IPs so that the images will load properly.

    How to install SOAP ? Thanks :rolleyes:
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    apt-get install php7.x-soap

    Replace x with the minor php version, e.g. 2 or 3 or 4 or whatever PHP version softaculous uses.
     
  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The message says
    It also says
     
  12. yatoula

    yatoula New Member

    Ok, now soap is good, but i create a new topic.
    Becaus e i create a user, create site and the site not lokk in my web browser
    kikou.eu


    i create a DNS in the account user ..i active DNSSEC with NS1 and NS2 , and now it's good ??
    why i have to create a DNS zone manually
     
    Last edited: Mar 29, 2020
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    You did not create a new topic, but continued with the same.
    Did you actually set up DNSSEC? https://en.wikipedia.org/wiki/Domain_Name_System_Security_Extensions
    You wrote "now it's good??". Is it working now or not? Or were you asking a question?
    Is this about ISPConfig? ISPConfig can not know if a zone must be created nor how zone should be set up. That is why you must create it yourself, either in ISPConfig or with some outside service.
     
  14. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    The '20151012' directory is specific to 7.0, it will not work for 7.2. Each php version points to a different path (7.2 happens to be '20170718'). You can cut&paste the code from this issue and it will configure all your php versions/modes with available ioncube loaders.
     
  15. kameleon1er

    kameleon1er Member

    Hi, I need PHP 7.4 for my wordpress installations, but I read that is only for Buster and I'm under Stretch.
    I found an interesting video there for PHP7.4 for Debian :
    but I don't want break my fresh install of ispConfig still in progress.
    What do you think about ?
    Thanks
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

  17. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  18. kameleon1er

    kameleon1er Member

    Hi, ok, I did the source forge's how-to, you show but :
    Code:
    ll php7.4-sqlite3 php7.4-tidy php7.4-xmlrpc php7.4-xsl php7.4-zip php7.4-mbstring php7.4-soap php7.4-opcache libonig5 php7.4-common php7.4-json php7.4-readline php7.4-xml
    Reading package lists... Done
    Building dependency tree      
    Reading state information... Done
    E: Unable to locate package libonig5
    Unable to locate package libonig5

    after, 7.3 maximum :
    Code:
      Selection    Path             Priority   Status
    ------------------------------------------------------------
    * 0            /usr/bin/php7.3   73        auto mode
      1            /usr/bin/php5.6   56        manual mode
      2            /usr/bin/php7.0   70        manual mode
      3            /usr/bin/php7.1   71        manual mode
      4            /usr/bin/php7.2   72        manual mode
      5            /usr/bin/php7.3   73        manual mode
     
  19. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Which howto?
    That package is available for Debian 10 Buster, not for older releases. Unless it is available from that Sury repo?
    https://packages.debian.org/buster/libonig5
     
  20. kameleon1er

    kameleon1er Member

Share This Page