Upgrade php 4.3 to php 4.4.1 ?

Discussion in 'Installation/Configuration' started by Hotwire, Apr 10, 2007.

  1. Hotwire

    Hotwire New Member

    I need to upgrade my :80 php to 4.4.1. Im running FC3. How do I go about this, without breaking everything already installed?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    You can use
    Code:
    yum search php
    to check if there are updated PHP versions. If so, you can install them by running
    Code:
    yum install [I]package_name[/I]
     
  3. 3cwired_com

    3cwired_com New Member

    I wanted to do the same thing, I tried your suggestions, and I was unable to get anything updated, I just did the usual yum and it did however update my php to a 4.3.9-3.22.5 from a smaller revision from before, but how do I make it update to the 4.4.x like the person asked above, it seems as if it will never do that, just do small updates within the same versioning???
     
  4. falko

    falko Super Moderator ISPConfig Developer

    It's possible that this version already contains all the patches and fixes that are in 4.4. Linux distributors often do this without increasing the version number.
     
  5. 3cwired_com

    3cwired_com New Member

    Falko, you are a genius, I was about to quit, give up my endeavours on installing ez publish because of the lame requirements for the software, and after I ran a yum update just to be sure, that my php 4.3.x was updated. I went ahead and tried a few versions of ez publish, that clearly stated that it needed php 4.4.x to run, and the newest version of ez publish didn't run, so i went back a few versions, and I was delighted to see them all work, so then i tried version 3.9.1, which is the second newest version, this version works with my setup.

    I have now actually populated it with most of my data and I have it in place.

    Again thanks man! Next time you come to Miami/ South Florida USA, I owe you a few beers!!!!
     

Share This Page