Upgrade Ispconfig3 breaks

Discussion in 'Installation/Configuration' started by shajazzi, Aug 23, 2015.

  1. shajazzi

    shajazzi Member

    I have just recently had to switch to an emergency Dell laptop sever after my main server took a dive.
    Everything was working fine until I upgraded Ispconfig to Ispconfig
    I can login ok but the images are bleeding and none of the menus on the left are active.
    I tried to upgrade again and received the following errors:
    Parse error: syntax error, unexpected '[' in /usr/local/ispconfig/server/plugins-available/mongo_clientdb_plugin.inc.php on line 260
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Are you sure, that you upgraded to Looks more like 3.1
  3. shajazzi

    shajazzi Member

    Hi Florian,
    Please see attached screenshot.


    Attached Files:

  4. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    I think you mixed-up p8 with 3.1 - has no support for mongodb and there is no file called plugins-available/mongo_clientdb_plugin.inc.php in the latest release.
  5. shajazzi

    shajazzi Member

    What do you suggest I do to try to resolve this, is it possible to delete ispconfig3 and reinstall with saved data bases?
    Your help would much appreciated.
    Last edited: Aug 23, 2015
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not possible. You will have to restore the previous ispconfi version from a backup. ISPConfig creates a backup in /var/backup during update.

Share This Page