Upgrade ISPConfig 3 with Data from old debian to newest one

Discussion in 'Installation/Configuration' started by iceget, Feb 18, 2016.

  1. iceget

    iceget Member

    Dear team,

    i have 2 servers.
    1. web01, Debian 7.8
    2. web02, Debian 6.0
    All Versions from ISPConfig are up to date.

    How i can migrate all servers to a new installed servers?
    i have tried this with apt upgrade, but this has not worked for me.

    if i now install a new virtual server with the latest debian, how i can migrate the old data to the new server?
    i mean; settings, ispconfig, webhost, mysqldbs ...

    can anybody help me?

    thanks
     
  2. ztk.me

    ztk.me Active Member

    There are several instructions in the forum already. Basically you have to setup server first and then clone data ( mail, webs, databases! ).
    You should pay attention that cloning the mysql data also clones your old root and debian-sys-maint password, so you also want to copy /etc/mysql/debian.cnf and if you use innodb, make sure you also copy my.cnf

    Afterwards run a resync on tools page which should reconfigure cronjobs, vhosts ect. That may take a while, be patient.
    Pay close attention how to clone data - if you don't copy your passwd and group files from /etc/ before unpacking you could end up in many ownership missmatches.
     
  3. iceget

    iceget Member

    thank you. what is better, setup a fresh server, or upgrade an existing server?

    thanks
     
  4. ztk.me

    ztk.me Active Member

    Both has pro and cons.
    If you have configured some additional services and such you probably will need more time to do a new setup than by fixing minor issues eventually appearing after an upgrade from 6>7 and then 7>8.
    It's something you'd probably need to test for yourself - you could do a dry run on a virtual box and setup new ISPConfig and merge data, test some logins and check if something's missing or not working.
    Really, I can't decide that for you, I'd do an upgrade on rolling release systems like debian, usually works.

    Maybe debian 9 will be a reason to do a clean reinstall.
     

Share This Page