Upgrade from Wheezy

Discussion in 'ISPConfig 3 Priority Support' started by Dextros, Aug 19, 2017.

  1. Dextros

    Dextros Member

    Hi Guys
    My server is fully operational, but i would like newer features, like Collabora. To do this i need up to date repos that are available for Jessie. My main sticking point at the moment is creating LE/Certbot cert outside of ISP. I run it standalone, but i get errors
    The apache plugin is not working; there may be problems with your existing configuration.
    The error was: NotSupportedError('Apache plugin support requires libaugeas0 and augeas-lenses version 1.2.0 or higher, please make sure you have you have those installed.',) For clarification these are installed.

    I have tried getting this working on Wheezy but I have now given up.
    I know how to upgrade, but I am worried about loosing data and having downtime. I have a backup, but my home connection would take a long time to get that amount of data back to the server in case of total lose.

    What are the chances of things breaking? and is it worth to jump to Stretch after a successful Jessie upgrade?
    Thanks for your input.
    Last edited: Aug 19, 2017
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Your setup seems to have problems already as LE would work otherwise, so it is not easy to predict if you will get problems during update. Normally, an update from Wheezy to Jessie is not a problem. Just update the operating system first and then do an ISPConfig update.

    Does LE within ISPConfig work?
  3. Dextros

    Dextros Member

    Hi Till
    Yes LE works within ISP and all sites are encrypted. Its only when i use the CL. I suppose i could make a sub domain and do it that way and do it through ISPC, and then manually add what i need to the vhost file.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, that might be a good idea. Most likely you can add the additional code for the site trough the apache / nginx directives field without having to edit the vhost file directly.
  5. Dextros

    Dextros Member

    Hi Till
    Finally got around to doing the upgrade
    I am confident that I have broken APache.
    Can I pay for someone to look at it and fix it. I will pay extra if this can be done today?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. Dextros

    Dextros Member

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This is nothing that can be configured in php.ini. You will have to reconfigure the Debian default php version. What is the result from command:

    php --version

    and post the output of the command:

    which php
  9. Dextros

    Dextros Member

    Thanks Till.

    php --version
    PHP 7.0.23-1+0~20170902060745.6+jessie~1.gbpa985da (cli) (built: Sep 2 2017 19:17:33) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.23-1+0~20170902060745.6+jessie~1.gbpa985da, Copyright (c) 1999-2017, by Zend Technologies

    which php
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    You updated from Wheezy to Jessie (8) and not Stretch (9), right? In this case, the PHP 7 must be from a third party repository as stretch is the first Debia Release with PHP 7. Which third party repo do you use, dotdeb?

    What is the result of the commands:

    which php5
    which php56
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    and post the output of:

    ls -la /etc/alternatives/php
  12. Dextros

    Dextros Member

    Correct. I updates to Jessie.
    Dotdeb was used.

    which php5 /usr/bin/php5
    which php56 blank

    lrwxrwxrwx 1 root root 15 Sep 17 13:22 /etc/alternatives/php -> /usr/bin/php7.0
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    please run these commands:

    mv /etc/alternatives/php /etc/alternatives/php-bak
    ln -s /usr/bin/php5 /etc/alternatives/php

    this should switch the system php back to 5.6.
  14. Dextros

    Dextros Member

    Yes that did. But I used dotdeb 5.6 also. so the module is still not there.
    Which modules should i re-enable?
    PHP 5.6.31-1~dotdeb+7.1 (cli) (built: Jul 10 2017 17:58:17)
    Copyright (c) 1997-2016 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

    [Sun Sep 17 15:00:06.251590 2017] [ssl:error] [pid 24474] AH02567: Unable to configure certificate isc.inspiredsolutionsuk.com:8090:0 for stapling
    [Sun Sep 17 15:00:06.254688 2017] [mpm_prefork:notice] [pid 24474] AH00163: Apache/2.4.10 (Debian) mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.9 mod_python/3.3.1 Python/2.7.9 OpenSSL/1.0.1t configured -- resuming normal operations
    [Sun Sep 17 15:00:06.254702 2017] [core:notice] [pid 24474] AH00094: Command line: '/usr/sbin/apache2'
    [Sun Sep 17 15:03:11.825310 2017] [fcgid:warn] [pid 25039] [client 8xx572] mod_fcgid: stderr: PHP Fatal error: Class 'mysqli' not found in /usr/local/ispconfig/interface/lib/classes/db_mysql.inc.php on line 30

    I appreciate your help, as always!

    I assume that I can pull the old php.ini from the backups and replace them?
    Last edited: Sep 17, 2017
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    I don't think that this problem is related to the php.ini as modules are not configured there. The most likely reason is that the php mysql modules from dotdeb are not installed at all. Modules om Debian are configured by small include files. Please try to install the mysqlnd modules.

    You can search for them with:

    apt-cache search mysqlndor:

    apt-cache search php | grep mysqltry to find the one for the PHP 5.6.31-1~dotdeb php version and install it.
  16. Dextros

    Dextros Member

    Hi Till

    Both of these came back empty

    There was this package

    The following packages have unmet dependencies:
    php5-mysqlnd : Depends: php5-common (= 5.6.30+dfsg-0+deb8u1) but 5.6.31-1~dotdeb+7.1 is to be installed
    E: Unable to correct problems, you have held broken packages.

  17. Dextros

    Dextros Member

    Just as a side note, this is the result of info.php
    Last edited: Sep 17, 2017
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    The phpinfo output is from a website, that's a different PHP than on the commandline. The commandline PHP has no mysql support currentntly and that's why it fails.
  19. Dextros

    Dextros Member

    Ok no worries. I didnt know if it would be useful information.
    I have requested support from Florian so we will see if he can undo my mess :oops:

    It says that there is no loaded config file;
    php --ini
    Configuration File (php.ini) Path: /etc/php5/cli
    Loaded Configuration File: (none)
    Scan for additional .ini files in: /etc/php5/cli/conf.d
    Additional .ini files parsed: /etc/php5/cli/conf.d/05-opcache.ini,
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    It says that it is loading /etc/php5/cli/conf.d/20-mysqli.ini, so mysqli support should be there. Are you sure that you still get the error about missing mysqli functions from ispconfig? and you ight check tat file to see if it loads the mysqli extension.

Share This Page