Upgrade from wheezy to jessie break apache.

Discussion in 'Installation/Configuration' started by nikos, Jul 30, 2015.

  1. nikos

    nikos New Member

    Hello, I ve used this tutorial https://www.howtoforge.com/tutorial/how-to-upgrade-debian-wheezy-to-jessie-stable-release/ to upgrade to jessie. First I ve used this tutorial to install everything https://www.howtoforge.com/perfect-server-debian-wheezy-apache2-bind-dovecot-ispconfig-3

    My problem is that Apache and postfix doesn't start. I need help cause no sites are running currently

    apache log
    Code:
    [Thu Jul 30 02:19:19 2015] [error] [client 222.186.30.211] script '/var/www/POST_ip_port.php' not found or unable to stat, referer: http://123.249.24.233/POST_ip_port.phpAccept: */*
    [Thu Jul 30 06:35:28 2015] [error] [client 222.186.30.211] script '/var/www/POST_ip_port.php' not found or unable to stat, referer: http://123.249.24.233/POST_ip_port.phpAccept: */*
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cgi/conf.d/ming.ini on line 1 in Unknown on line 0
    [Thu Jul 30 06:58:09 2015] [error] [client 222.186.129.5] script '/var/www/POST_ip_port.php' not found or unable to stat, referer: http://123.249.24.233/POST_ip_port.phpAccept: */*
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cgi/conf.d/ming.ini on line 1 in Unknown on line 0
    [Thu Jul 30 07:17:42 2015] [error] [client 222.186.129.5] script '/var/www/POST_ip_port.php' not found or unable to stat, referer: http://123.249.24.233/POST_ip_port.phpAccept: */*
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cgi/conf.d/ming.ini on line 1 in Unknown on line 0
    [Thu Jul 30 11:02:59 2015] [error] [client 127.0.0.1] script '/var/www/rpc.php' not found or unable to stat
    [Thu Jul 30 11:02:59 2015] [error] [client 127.0.0.1] script '/var/www/rpc.php' not found or unable to stat
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/cgi/conf.d/ming.ini on line 1 in Unknown on line 0
    [Thu Jul 30 12:06:08 2015] [notice] caught SIGTERM, shutting down
    [Thu Jul 30 12:06:10 2015] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Jul 30 12:06:10 2015] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Thu Jul 30 12:06:10 2015] [warn] module php5_module is already loaded, skipping
    [Thu Jul 30 12:06:10 2015] [notice] Digest: generating secret for digest authentication ...
    [Thu Jul 30 12:06:10 2015] [notice] Digest: done
    [Thu Jul 30 12:06:10 2015] [notice] FastCGI: process manager initialized (pid 849)
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
    [Thu Jul 30 12:06:11 2015] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
    [Thu Jul 30 12:06:11 2015] [error] python_init: Python executable found '/usr/bin/python'.
    [Thu Jul 30 12:06:11 2015] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Thu Jul 30 12:06:11 2015] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Thu Jul 30 12:06:11 2015] [notice] mod_python: using mutex_directory /tmp
    [Thu Jul 30 12:06:11 2015] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Jul 30 12:06:11 2015] [notice] Apache/2.2.22 (Debian) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.4.41-0+deb7u1 mod_python/3.3.1 Python/2.7.3 mod_ruby/1.2.6 Ruby/1.8.7(2012-02-08) mod_scgi/1.13 mod_ssl/2.2.22 OpenSSL/1.0.1e configured -- resuming normal operations
    [Thu Jul 30 12:09:15 2015] [notice] Graceful restart requested, doing restart
    [Thu Jul 30 12:09:15 2015] [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
    [Thu Jul 30 12:09:18 2015] [warn] module php5_module is already loaded, skipping
    [Thu Jul 30 12:09:18 2015] [warn] NameVirtualHost 1.1.1.1:80 has no VirtualHosts
    [Thu Jul 30 12:09:18 2015] [warn] NameVirtualHost 1.1.1.1:443 has no VirtualHosts
    [Thu Jul 30 12:09:18 2015] [notice] Digest: generating secret for digest authentication ...
    [Thu Jul 30 12:09:18 2015] [notice] Digest: done
    [Thu Jul 30 12:09:19 2015] [notice] FastCGI: process manager initialized (pid 25015)
    PHP Deprecated:  Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
    [Thu Jul 30 12:09:19 2015] [error] python_init: Python version mismatch, expected '2.7.2+', found '2.7.3'.
    [Thu Jul 30 12:09:19 2015] [error] python_init: Python executable found '/usr/bin/python'.
    [Thu Jul 30 12:09:19 2015] [error] python_init: Python path being used '/usr/lib/python2.7/:/usr/lib/python2.7/plat-linux2:/usr/lib/python2.7/lib-tk:/usr/lib/python2.7/lib-old:/usr/lib/python2.7/lib-dynload'.
    [Thu Jul 30 12:09:19 2015] [notice] mod_python: Creating 8 session mutexes based on 150 max processes and 0 max threads.
    [Thu Jul 30 12:09:19 2015] [notice] mod_python: using mutex_directory /tmp
    [Thu Jul 30 12:09:19 2015] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
    [Thu Jul 30 12:09:19 2015] [notice] Apache/2.2.22 (Debian) DAV/2 mod_fastcgi/mod_fastcgi-SNAP-0910052141 mod_fcgid/2.3.6 PHP/5.4.41-0+deb7u1 mod_python/3.3.1 Python/2.7.3 mod_scgi/1.13 mod_ssl/2.2.22 OpenSSL/1.0.1k configured -- resuming normal operations
    [Thu Jul 30 12:09:19 2015] [warn] long lost child came home! (pid 848)
    [Thu Jul 30 12:12:32 2015] [notice] caught SIGTERM, shutting down
     
    Last edited: Jul 30, 2015
  2. nikos

    nikos New Member

    Ok, I went to ssl.conf file and commented out
    Code:
    SSLMutex  file:${APACHE_RUN_DIR}/ssl_mutex
    Now it works but is this OK?

    Looks like that during the upgrade process it added an extra line to my config file which didn't be added to separate line but at the end of the last line and that did the conflict.
    Still smtp-server doesn't run though
     
    Last edited: Jul 30, 2015
  3. nikos

    nikos New Member

    SMTP now is up but no email is received or sent.
    Code:
    Jul 30 13:53:31 sd postfix/submission/smtpd[5998]: timeout after END-OF-MESSAGE from unknown[188.73.192.127]
    Jul 30 13:53:59 sd- postfix/submission/smtpd[5667]: disconnect from unknown[188.73.192.127]
    Jul 30 13:54:04 sd- dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=188.73.192.127, lip=1.1.1.1, mpid=6538, TLS, session=<j08oXBYc5gC8ScB/>
    Jul 30 13:54:04 sd- dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=188.73.192.127, lip=1.1.1.1, mpid=6539, TLS, session=<f1spXBYcZgC8ScB/>
    Jul 30 13:54:05 sd- dovecot: imap([email protected]): Connection closed in=50 out=1007
    Jul 30 13:54:05 sd- dovecot: imap([email protected]): Connection closed in=122 out=1445
    Jul 30 13:54:07 sd- dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=188.73.192.127, lip=1.1.1.1, mpid=6541, TLS, session=<0YVNXBYcPgC8ScB/>
    Jul 30 13:54:08 sd- dovecot: imap([email protected]): Connection closed in=149 out=1379
    Jul 30 13:54:19 sd- postfix/submission/smtpd[5667]: warning: hostname pppgint-19273-127.b-online.gr does not resolve to address 188.73.192.127: Name or service not known
    Jul 30 13:54:19 sd- postfix/submission/smtpd[5667]: connect from unknown[188.73.192.127]
    Jul 30 13:54:22 sd- dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=188.73.192.127, lip=1.1.1.1, mpid=6547, TLS, session=<DTM0XRYc1wC8ScB/>
    Jul 30 13:54:22 sd-41781 postfix/submission/smtpd[5667]: 2AF363A05EE: client=unknown[188.73.192.127], sasl_method=PLAIN, [email protected]
    Jul 30 13:54:22 sd-41781 postfix/cleanup[6548]: 2AF363A05EE: message-id=<>
    Jul 30 13:54:22 sd-41781 postfix/qmgr[1588]: 2AF363A05EE: from=<[email protected]>, size=524, nrcpt=1 (queue active)
    Jul 30 13:54:22 sd-41781 postfix/error[6549]: 2AF363A05EE: to=<[email protected]>, relay=none, delay=0.51, delays=0.46/0.04/0/0.01, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jul 30 13:54:22 sd-41781 dovecot: imap([email protected]): Connection closed in=50 out=1007
    Jul 30 13:54:26 sd-41781 postfix/scache[6317]: statistics: start interval Jul 30 13:51:06
    Jul 30 13:54:26 sd-41781 postfix/scache[6317]: statistics: domain lookup hits=0 miss=2 success=0%
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    amavis is not running.
     
  5. nikos

    nikos New Member

    I did check it and it runs
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

  7. nikos

    nikos New Member

    It has 3 running processes,
    1782 amavis 0.1 % /usr/sbin/amavisd-new (master)
    2016 amavis 0.0 % /usr/sbin/amavisd-new (virgin child)
    2017 amavis 0.0 % /usr/sbin/amavisd-new (virgin child)
    Still can't send/receive email
    Code:
    Jul 30 14:16:27 sd- postfix/submission/smtpd[8071]: warning: hostname pppgint-19273-127.b-online.gr does not resolve to address 188.73.192.127: Name or service not known
    Jul 30 14:16:27 sd- postfix/submission/smtpd[8071]: connect from unknown[188.73.192.127]
    Jul 30 14:16:30 sd- dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=188.73.192.127, lip=1.1.1.1, mpid=8076, TLS, session=<srVerBYc+AC8ScB/>
    Jul 30 14:16:30 sd- postfix/submission/smtpd[8071]: 722EA3A0704: client=unknown[188.73.192.127], sasl_method=PLAIN, [email protected]
    Jul 30 14:16:30 sd- postfix/cleanup[8079]: 722EA3A0704: message-id=<>
    Jul 30 14:16:30 sd- postfix/qmgr[1588]: 722EA3A0704: from=<[email protected]>, size=540, nrcpt=1 (queue active)
    Jul 30 14:16:30 sd- postfix/error[8080]: 722EA3A0704: to=<[email protected]>, relay=none, delay=0.59, delays=0.57/0.02/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
    Jul 30 14:16:30 sd- dovecot: imap([email protected]): Connection closed in=50 out=1007
    Here the command via ssh
    Code:
    root@sd-:~# /etc/init.d/amavis start
    [ ok ] Starting amavis (via systemctl): amavis.service.
    root@sd-:~# /etc/init.d/amavis restart
    [ ok ] Restarting amavis (via systemctl): amavis.service.
    
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    any errors in mail.log when you restart amavis?
     
  9. nikos

    nikos New Member

    No errors, I've pasted the latest log in previous post
     

Share This Page