Upgrade from 34 -> 35 went horribly wrong

Discussion in 'Installation/Configuration' started by demortes, Apr 15, 2010.

  1. demortes

    demortes Member


    I upgraded my version of ISPConfig from 2.2.34 to 2.2.35 and now my apache wont run, my ISPconfig panel wont run. When I try, it complains about certificates not in existence.

    I decided to rerun the upgrade, simply because I know I received an error, but everything completed seemingly successfully. When I rebooted, I lost the error. Now when I run it I get:

    Checking the syntax of the httpd.conf...
    Syntax error on line 144 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
    SSLCertificateChainFile: file '/root/ispconfig/httpd/conf/ssl.crt/sub.class2.server.ca.crt' does not exist or is empty
    ERROR: The syntax of your httpd.conf is not ok! Please correct the error. The installation routine stops here!
    [email protected]:~/upgrade_ispconfig/install_ispconfig#
    Checking that directory (/root/ispconfig) I only have the following directory structure:

    And that directory is empty. I'm not sure what I did wrong, and where to begin, but I would like to maintain my websites and get this back and running.

    System versions:

    [email protected]:~/ispconfig/isp/conf/customized_templates# gcc -v
    Using built-in specs.
    Target: i486-linux-gnu
    Configured with: ../src/configure -v --with-pkgversion='Ubuntu 4.4.1-4ubuntu9' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --program-suffix=-4.4 --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-targets=all --disable-werror --with-arch-32=i486 --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
    Thread model: posix
    gcc version 4.4.1 (Ubuntu 4.4.1-4ubuntu9)

    Any help, I'll appreciate.

  2. demortes

    demortes Member

    In my impatience, I backed everything up as far as the web directories and the mysql DB's....

    Right now I'm running the install again after removing the ispconfig folder in /root.

    Seems to be going OK, but I'll post if anything goes wrong. Worse case scenario, I reinstall ubuntu (really not that big of a deal).

  3. demortes

    demortes Member

    Just to post for future users, I found that reinstalling worked well for me. It kept all my settings, I had to restore a vhost configuration file back to previous and I don't know if ISPConfig will overwrite that, but the site works, the control panel works and I had to redo my ssl certificates and configuration for ISPConfig, but everything is secured.

    Thanks to those who are reading with intent to help, but I seem to have it under control.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The error occured because you had put a ssl chain cert into a subfolder of the ispconfig installation, but apache gets updated and so the folders get replaced during the update so that your file was missing then. To avaoid this, do not store any custom files in the ispconfig source directorys. If you put the chain cert in e.g. /etc/ssl, you will not get a problem.
  5. demortes

    demortes Member

    That's a good idea. That's why you make good software, and I just put holes into them. :)

Share This Page