Upgrade failed, no ISPconfig, no backup...

Discussion in 'Installation/Configuration' started by gauthier, Apr 19, 2008.

  1. gauthier

    gauthier New Member

    Hi, I tried to upgrade from 2.2.21 to 2.2.23 on CENTOS 4.4

    Error occurs: "The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!" (It seems I have a virtual memory problem). OK.

    Then I tried to rerun .setup, see current ISPconfig instalation is not being reconized anymore (new instalation is running). So I stoped the process to avoid lost of data.

    I had a look in tmp directory with ls -la /tmp. It seems there is no backup available. Only one file have been created today, its name is sess_6a5sd6f54a6sdf(what ever)a56a4sdf654as , owner is adminispconfig, and size is 25 bytes (no KB).

    I have 3 question:

    1. What shall I do ?

    2. If there is a bakup of my ISPconfig installation, where is it, and which command(s) shall I run to restore it ?

    3. Maybe I can make a copy of my mysql database (the one related with ISPconfig) then install newly the 2.2.19 version of ISPconfig and then replace the mysql database... I remember Falko explained how to do this but I cannot find it anymore.

    Thanks for any help.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    mkdir /root/ispconfig

    and then run the ispconfig setup again. If you stopped the second setup run early enough, ISPConfig should be able to restore your installation.

    Afterwards, you will have to recreate the ssl certificates by following these instructions:

  3. gauthier

    gauthier New Member

    maybe datadase corrupted

    Thank you Till,

    I've done what you wrote.

    Also as I have read in http://howtoforge.com/forums/showthread.php?t=6414, I stoped all daemons except the ssh to avoid virtual memory error.

    ISPconfig instalation runs well.

    But now sites are not running anymore.

    I enter ISPconfig control panel.

    It seems in some way site are here but with problems:

    In "ISPmanager" I select "sites" and then "mysite.com" in the new window titled "ISP Site/basis", Server and Hostname are ok but Domain is blank !!!!

    I tried to fill it newly, this is the error message:

    This website already has 1 user(s). You cannot decrease the number of users.
    This website already has 1 domain(s). You cannot decrease the number of domains.
    This website already has 0 database(s). You cannot decrease the number of databases.
    error_web_no_list_decrease_10error_web_no_list_decrease_2This website already has 0 database(s). You cannot decrease the number of databases.
    Invalid domain name: ""

    I cannot enter "user&email" I am only allowed to see the "basis" window. Whatever I do error message is shown.

    Thanks if you have any suggestion.
  4. gauthier

    gauthier New Member

    It seems I successfuly repair the database


    Because all my sites shootdown I tried whatever.

    I openned ISPconfig database, find out that table isp_isp_web is empty and should not.

    I copy isp_isp_web table from database backup I found in /tmp (I had to remove the "web_ruby" column that does not exist anymore in version 2.2.23).

    All sites are now back, ISPconfig control panel runs well.

    Hope this wont create some missconfiguration in future, and if it is ok, I hope this could be an help for others.:eek:

    Thanks to Till.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig 2.2.23 has the web_ruby column, have a look in the sql dump of the installer package. It seems as if you accidently troed to downgrade your installation to a version which does not have the web_ruby column.

Share This Page