upgrade error from ispconfig 3.1.11 to 3.1.12

Discussion in 'General' started by jem, Jun 26, 2018.

  1. jem

    jem New Member

    Hi all, I need some help trying to upgrade ispconfig 3.1.11 to 3.1.12. I googled the error message but no luck.
    if someone could help me out that would be grate. bellow is the error message.

    Operating System: Ubuntu 16.04.4 LTS (Xenial Xerus)
    This application will update ISPConfig 3 on your server.
    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:
    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    Fatal error: Uncaught Error: Call to undefined function mysqli_connect() in /root/ispconfig3_install/install/update.php:239
    Stack trace:
    #0 {main}
    thrown in /root/ispconfig3_install/install/update.php on line 239
    [email protected]/tmp/ispconfig3_install/install#
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The PHP on your server is missing the mysqli extension. Please post the output of:

    which php
     
  3. jem

    jem New Member

    Thank you Till for replying. Which command do I run to get the output.
    I did a php -v and got the following.
    PhP 7.2.2 (cli)
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The command is:

    Code:
    which php
    the php -v output does not help here :)
     
  5. jem

    jem New Member

    Output for command which php /usr/local/bin/php
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you manually compiled a PHP version without MySQL support and placed it in /usr/local/bin instead of its own directory which overrides the system php now.

    Run:

    mv /usr/local/bin/php /usr/local/bin/php_bak

    and then do the update again.
     
  7. jem

    jem New Member

    Thank you Till. the issue has been resolved. I was able to upgrade to 3.1.12.
    I ran the which php again and got the following result.
    /usr/bin/php

    Thank you once again.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, that's the system php binary, which is the correct result for the query.
     
  9. drew954

    drew954 New Member

    Hi till,
    I am getting this same error on upgrade.
    When I run the command which php i get /usr/bin/php
    Any further suggestions for a fix?
    Thanks.
     
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Upgrading what?
    Has the upgrade removed the php module for mysql?
     

Share This Page