Upgrade apache

Discussion in 'Technical' started by vlados, Oct 22, 2010.

  1. vlados

    vlados New Member

    Hi,
    I have ubuntu with (according to apt latest version) apache 2.12. How can I upgrade to 2.17 or 2.3?
     
  2. falko

    falko Super Moderator ISPConfig Developer

    If there's no such package available from the Ubuntu repositories, you have to build Apache yourself (which I don't recommend!).
     
  3. vlados

    vlados New Member

    Yes, but hacker guardian tells me to upgrade, and that this is a security hole
     
  4. falko

    falko Super Moderator ISPConfig Developer

    You can be sure that Ubuntu will release an update if there's a security hole. Just run
    Code:
    apt-get update && apt-get upgrade
    to install the latest updates. If there's no update, then the hole is already fixed in the current package.
     
  5. vlados

    vlados New Member

    Code:
    IP Address
    
    Vulnerabilities Noted per IP address
    
    Severity level
    
    CVSS Score
    
    Exceptions, False Positives or Compensating Controls
    Noted by ASV for this Vulnerability
    
    Compliance Status
    
    www.netlabs.bg
    
    
    Apache 2.2 < 2.2.15 Multiple Vulnerabilities http (80/tcp) 
     CVE-2009-3555, CVE-2010-0408, CVE-2010-0425, CVE-2010-0434
    
    High
    
    
     10.
    
    
     
    
    
    Fail
    
    
    www.netlabs.bg
    
    
    Apache 2.2 < 2.2.15 Multiple Vulnerabilities http-alt (8080/tcp) 
     CVE-2009-3555, CVE-2010-0408, CVE-2010-0425, CVE-2010-0434
    
    High
    
    
     10.
    
    
     
    
    
    Fail
    
    
    www.netlabs.bg
    
    
    Apache 2.2 < 2.2.15 Multiple Vulnerabilities https (443/tcp) 
     CVE-2009-3555, CVE-2010-0408, CVE-2010-0425, CVE-2010-0434
    
    High
    
    
     10.
    
    
     
    
    
    Fail
    
    
    www.netlabs.bg
    
    
    Apache 2.2 < 2.2.14 Multiple Vulnerabilities http (80/tcp) 
     CVE-2009-2699, CVE-2009-3094, CVE-2009-3095
    
    High
    
    
     7.5
    
    
     
    
    
    Fail
    
    
    www.netlabs.bg
    
    
    Apache 2.2 < 2.2.14 Multiple Vulnerabilities http-alt (8080/tcp) 
     CVE-2009-2699, CVE-2009-3094, CVE-2009-3095
    
    High
    
    
     7.5
    
    
     
    
    
    Fail
    
    
    www.netlabs.bg
    
    
    Apache 2.2 < 2.2.14 Multiple Vulnerabilities https (443/tcp) 
     CVE-2009-2699, CVE-2009-3094, CVE-2009-3095
    
    High
    
    
     7.5
    
    
     
    
    
    Fail
    
     

Share This Page