Updating to 3.1.11 from 3.1.9 on Debian9

Discussion in 'General' started by vk3heg, Jan 12, 2018.

  1. vk3heg

    vk3heg Member

    Hi Guys,
    Debian 9, with all updates installed. I get this error on trying to update ispconfig:

    [email protected]:/tmp/ispconfig3_install/install# php -q update.php
    >> Update
    Operating System: Debian 9.0 (Stretch) or compatible
    This application will update ISPConfig 3 on your server.
    Shall the script create a ISPConfig backup in /var/backup/ now? (yes,no) [yes]:
    Creating backup of "/usr/local/ispconfig" directory...
    Creating backup of "/etc" directory...
    PHP Fatal error: Uncaught Error: Call to undefined function mysqli_connect() in /tmp/ispconfig3_install/install/update.php:234
    Stack trace:
    #0 {main}
    thrown in /tmp/ispconfig3_install/install/update.php on line 234

    Recommendation on how to fix?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    There is PHP module not installed. Somehow you missed those when setting up ISPConfig.
    You have to install the php-mysql and php-mysqli extensions from your linux distribution.
     

Share This Page