Updating Server

Discussion in 'Installation/Configuration' started by Morons, Jul 12, 2007.

  1. Morons

    Morons Member

    I am running clamdscan and would like to upgrade the server software from time to time. However on ubuntu running the command
    apt-get upgrade
    I get the following results.
    [email protected]:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages have been kept back:
      linux-image-server linux-server
    The following packages will be upgraded:
      clamav-base clamav-daemon clamav-freshclam file libapache2-mod-php5 libclamav2 libfreetype6 libgd2-xpm libmagic1 libpng12-0
      linux-libc-dev php-pear php5 php5-cli php5-common php5-curl php5-dev php5-gd php5-mhash php5-mysql php5-pspell php5-recode
      php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl python python-gdbm python-minimal python2.5 python2.5-minimal
      update-manager-core vim-common vim-tiny
    35 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
    Need to get 23.6MB of archives.
    After unpacking 4096B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    WARNING: The following packages cannot be authenticated!
      vim-tiny vim-common file libmagic1 clamav-base libclamav2 clamav-freshclam clamav-daemon php5-cli php5-mysql php5-mhash
      php5-xsl php5-pspell php5-snmp php5-curl php5-recode php5-xmlrpc php5-sqlite libfreetype6 libpng12-0 libgd2-xpm php5-gd
      php5-tidy libapache2-mod-php5 php5-common linux-libc-dev php-pear php5 php5-dev
    Install these packages without verification [y/N]? n
    E: Some packages could not be authenticated
    Cautious I said no. ISPC compile and config php5 in the upgrade packages and some others that I dont have a list of. This will cause some issues.
    Would be the correct procedure be to 1st upgrade ISPC to latest and then run an upgrade, witch files/modules must we watch for :confused:
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Updating your ubuntu setup does not intefere with the ISPConfig packages. The above warmings have nothing to do with the ISPConfig php5.

    You should check your /etc/apt/sources.list and make sure that you use a official mirror for your packages.
  3. Morons

    Morons Member

    Yes the /etc/apt/sources.list is as per install, It seem to be localised to the country you selected when first installing.
    apt-get update
    was run before
  4. falko

    falko Super Moderator ISPConfig Developer

    If you're using the official mirrors, I'd say it's safe to install the updates.

Share This Page