Updated to 3.0.1.6: Squirrelmail 403 Forbidden Access

Discussion in 'General' started by astewart, Oct 22, 2009.

  1. astewart

    astewart ISPConfig Developer ISPConfig Developer

    Hi guys,
    I am no longer able to access webmail (squirrelmail) from any of my domains:
    eg. http://www.example.com/webmail

    I get the custom ispconfig 403 Forbidden Page.
    This just started to happen right after I updated from ISPCONFIG 3.0.1.4 to 3.0.1.6.

    I have verified that the webmail Symlink still exists in /var/www/ and the apache file for squirrelmail has not changed either.

    Permissions / User issue? :confused: :confused:

    Does anyone have any ideas why this is happening now and what I might be able to try to get webmail working again?

    Thanks!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. astewart

    astewart ISPConfig Developer ISPConfig Developer

    I updated last night by simply running 'ispconfig_update.sh' from the command line.
    I updated from version 3.0.1.4 to 3.0.1.6.

    It shows I'm running the latest version as well.



    Should I try a manual update this time?
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, not nescessary. Where exactly are the source files of squirrelmail located in your installation?
     
  5. astewart

    astewart ISPConfig Developer ISPConfig Developer

    The squirrelmail source files are all located in:
    /usr/share/webmail
     
  6. astewart

    astewart ISPConfig Developer ISPConfig Developer

    Just to add, I have tried renaming the .htaccess just to see if that was causing the problem on one of my sites but no difference.

    The following symlink is also created in /var/www/
    Here is the squirrelmail vhost info:
    I have no idea why this update would break this.
    Any ideas?
     
    Last edited: Oct 23, 2009
  7. astewart

    astewart ISPConfig Developer ISPConfig Developer

    Here is a snip from the error.log file from one of my Domains:
     
  8. astewart

    astewart ISPConfig Developer ISPConfig Developer

    I fixed the issue!
    Previously, I've always had my custom squirrelmail source code in '/usr/share/webmail' and it has always worked like this.

    I verified the 'ispconfig.conf' and it shows the following:
    I know ISPCONFIG would over-write my changes if I modified that, so I just made a copy of the webmail directory and called it squirrelmail, reloaded apache and now everything works.

    :)
     

Share This Page