Updated ispconfig3, squirrelmail no longer finds email

Discussion in 'General' started by dragostini, Apr 14, 2017.

  1. dragostini

    dragostini New Member

    Hi everyone,
    Running Ubuntu 14.04 on a remote server quite happily with ispconfig3, squirrelmail, postfix and dovecot.

    Ran into an issue where I could no longer reach my ispconfig admin panel, and hadn't updated ispconfig in forever, nor postfix or dovecot.

    Decided to update everything.

    I now have this issue where when I log into squirrelmail I see my OLD emails, and can send emails, but I can't receive them. The postfix logs show that the email is received, but they do not show up in the squirrelmail inboxes.

    Checking /var/vmail/mydomain/myuser shows files, and that is where ispconfig3 seems to be creating new inboxes (I tried making new mailboxes for @mydomain in ispconfig to see where it made the inbox) but no mail in the /new directory. Also, even though ispconfig is making those email inboxes, if I send mail to a NEW email address I make from my gmail account, it bounces back saying the inbox does not exist. So, something is looking at the wrong directory....

    My postfix main.cf:
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    #home_mailbox= /Maildir
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = /usr/share/doc/postfix
    
    # TLS parameters
    #smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    #smtpd_tls_key_file = /etc/postfix/smtpd.key
    #smtpd_use_tls = yes
    #smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    #smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtpd_tls_security_level = may
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_loglevel = 1
    smtpd_tls_auth_only = yes
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    smtp_tls_session_cache_database = btree:$data_directory/smtp_tls_session_cache
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_helo_required = yes
    smtpd_helo_restrictions = permit_sasl_authenticated, permit_mynetworks, check_helo_access regexp:/etc/postfix/helo_access, reject_invalid_hostname, reject_non_fqdn_hostname, check_helo_access regexp:/etc/postfix/blacklist_helo
    smtpd_data_restrictions = reject_unauth_pipelining
    smtpd_delay_reject = yes
    # applied crypto settings
    smtp_tls_security_level = may
    smtp_tls_loglevel = 1
    # tls_ssl_options = NO_COMPRESSION
    smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3
    smtpd_tls_mandatory_ciphers = high
    tls_high_cipherlist=EDH+CAMELLIA:EDH+aRSA:EECDH+aRSA+AESGCM:EECDH+aRSA+SHA384:EECDH+aRSA+SHA256:EECDH:+CAMELLIA256:+AES256:+CAMELLIA128:+AES128:+SSLv3:!aNULL:!eNULL:!LOW:!3DES:!MD5:!EXP:!PSK:!DSS:!RC4:!SEED:!ECDSA:CAMELLIA256-SHA:AES256-SHA:CAMELLIA128-SHA:AES128-SHA
    smtpd_tls_eecdh_grade = ultra
    tls_preempt_cipherlist = yes
    smtp_tls_loglevel= 1
    
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = testbawks.com
    alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
    myorigin = /etc/mailname
    mydestination = testbawks.com, localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8 [::1]/128
    mailbox_command = procmail -a "$EXTENSION"
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = hash:/var/lib/mailman/data/virtual-mailman, proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /var/vmail
    virtual_uid_maps = mysql:/etc/postfix/mysql-virtual_uids.cf
    virtual_gid_maps = mysql:/etc/postfix/mysql-virtual_gids.cf
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_rbl_client zen.spamhaus.org
    smtpd_tls_security_level = may
    transport_maps = hash:/var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
    relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $sender_bcc_maps $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $smtpd_sender_login_maps
    smtpd_sender_restrictions = check_sender_access regexp:/etc/postfix/tag_as_originating.re , permit_mynetworks, permit_sasl_authenticated, check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf, check_sender_access regexp:/etc/postfix/tag_as_foreign.re
    smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
    smtpd_client_message_rate_limit = 100
    maildrop_destination_concurrency_limit = 1
    maildrop_destination_recipient_limit = 1
    virtual_transport = dovecot
    header_checks = regexp:/etc/postfix/header_checks
    mime_header_checks = regexp:/etc/postfix/mime_header_checks
    nested_header_checks = regexp:/etc/postfix/nested_header_checks
    body_checks = regexp:/etc/postfix/body_checks
    owner_request_special = no
    smtp_tls_security_level = may
    #ssl_protocols = TLSv1 TLSv1.1 TLSv1.2;
    #smtpd_tls_mandatory_protocols = !SSLv2, !SSLv3
    smtpd_tls_protocols = !SSLv2,!SSLv3
    smtp_tls_protocols = !SSLv2,!SSLv3
    dovecot_destination_recipient_limit = 1
    smtpd_sasl_type = dovecot
    smtpd_sasl_path = private/auth
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    import_environment = MAIL_CONFIG MAIL_DEBUG MAIL_LOGTAG TZ XAUTHORITY DISPLAY LANG=C RESOLV_MULTI=on
    smtpd_tls_mandatory_exclude_ciphers = aNULL, eNULL, EXPORT, DES, RC4, MD5, PSK, aECDH, EDH-DSS-DES-CBC3-SHA, EDH-RSA-DES-CDC3-SHA, KRB5-DE5, CBC3-SHA
    smtpd_tls_dh1024_param_file = /etc/ssl/private/dhparams.pem
    smtp_helo_name = testbawks.com
    smtpd_relay_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf
    sender_bcc_maps = proxy:mysql:/etc/postfix/mysql-virtual_outgoing_bcc.cf
    smtpd_restriction_classes = greylisting
    greylisting = check_policy_service inet:127.0.0.1:10023
    smtpd_sender_login_maps = proxy:mysql:/etc/postfix/mysql-virtual_sender_login_maps.cf
    smtpd_tls_exclude_ciphers = RC4, aNULL
    smtp_tls_exclude_ciphers = RC4, aNULL
    message_size_limit = 0
    
    
    My dovecot.conf
    Code:
    listen = *,[::]
    protocols = imap pop3
    auth_mechanisms = plain login
    disable_plaintext_auth = no
    mail_location = /var/vmail/%d/%n/Maildir
    #mail_location: maildir:/var/vmail/%d/%n/Maildir
    log_timestamp = "%Y-%m-%d %H:%M:%S "
    mail_debug=yes
    mail_privileged_group = vmail
    postmaster_address = postmaster@squeek
    ssl_cert = </etc/postfix/smtpd.cert
    ssl_key = </etc/postfix/smtpd.key
    ssl_protocols = !SSLv2 !SSLv3
    mail_max_userip_connections = 100
    passdb {
    args = /etc/dovecot/dovecot-sql.conf
    driver = sql
    }
    userdb {
    driver = prefetch
    }
    userdb {
    args = /etc/dovecot/dovecot-sql.conf
    driver = sql
    }
    plugin {
    quota = dict:user::file:/var/vmail/%d/%n/.quotausage
    sieve=/var/vmail/%d/%n/.sieve
    sieve_max_redirects = 25
    }
    service auth {
    unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
    }
    unix_listener auth-userdb {
    group = vmail
    mode = 0600
    user = vmail
    }
    user = root
    }
    service lmtp {
    unix_listener /var/spool/postfix/private/dovecot-lmtp {
    group = postfix
    mode = 0600
    user = postfix
    }
    }
    service imap-login {
    client_limit = 1000
    process_limit = 512
    }
    protocol imap {
    mail_plugins = quota imap_quota
    }
    protocol pop3 {
    pop3_uidl_format = %08Xu%08Xv
    mail_plugins = quota
    }
    protocol lda {
    postmaster_address = webmaster@localhost
    mail_plugins = sieve quota
    }
    protocol lmtp {
    postmaster_address = webmaster@localhost
    mail_plugins = quota sieve
    }
    mail_plugins = $mail_plugins quota
    
    
     
  2. dragostini

    dragostini New Member

    enabled dovecot debug settings and see this, so from my untrained eyes, it looks fine?:

    Code:
    
    Apr 14 11:42:35 squeek dovecot: imap(dragostini@mydomain.com): Debug: Effective uid=5000, gid=5000, home=/var/vmail/mydomain.com/dragostini
    Apr 14 11:42:35 squeek dovecot: imap(dragostini@mydomain): Debug: Quota root: name=user backend=dict args=:file:/var/vmail/mydomain.com/dragostini/.quotausage
    Apr 14 11:42:35 squeek dovecot: imap(dragostini@mydomain.com): Debug: Quota rule: root=user mailbox=* bytes=0 messages=0
    Apr 14 11:42:35 squeek dovecot: imap(dragostini@mydomain.com): Debug: Quota grace: root=user bytes=0 (10%)
    Apr 14 11:42:35 squeek dovecot: imap(dragostini@mydomain.com): Debug: dict quota: user=dragostini@mydomain.com, uri=file:/var/vmail/mydomain.com/dragostini/.quotausage, noenforcing=0
    Apr 14 11:42:35 squeek dovecot: imap(dragostini@mydomain.com): Debug: maildir++: root=/var/vmail/mydomain.com/dragostini/Maildir, index=, indexpvt=, control=, inbox=/var/vmail/mydomain.com/dragostini/Maildir, alt=
    
    
     
  3. dragostini

    dragostini New Member

    Another update:

    Just checked ISPconfig, and it shows all the mailboxes I have been making in it's quota section and such on the hometab of my control panel. So it's not that the inboxes don't exist...but either postfix or dovecot or both are not configured properly I am assuming?
     
  4. dragostini

    dragostini New Member

    it looks like ALL MAIL is currently in the file /var/mail/dragostini not sure why
     
  5. dragostini

    dragostini New Member

    fixed by changing mydestination = mail.mydomain.com...
     
    ahrasis likes this.

Share This Page