Updated and now mail is broke

Discussion in 'Installation/Configuration' started by MrMoo, Sep 20, 2011.

  1. MrMoo

    MrMoo New Member

    im unable to send or recieve emails, i don't get any errors or bounce backs and when i type "mail" as root there is nothing waiting

    i just ran "yum update" it updated over 200 packages and it seems some of them included mail server updates.

    my dovecot/postfix install is now not working, ive not changed anything config wise

    my maillog contains the following when i send an email and the last few lines are when i check mail via squirrelmail

    my main.cf mydestination line looks like this

    i use the perfect server ceontOS 5 setup from this site which was working great until i just updated.

    I have also tried configuring a new centOS 6 server and have the same delivery/recieving issues.

    im in desperate need of help, many thanks.
     
  2. Mark_NL

    Mark_NL New Member

    Code:
    Sep 20 18:56:55 burtonc sendmail[3278]: p8KHutow003278: to=xxxxxx@hotmail.com, ctladdr=admin@xxxxxx.com (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30545, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection refused by [127.0.0.1]
    This line tells me the servers wants to relay your mail to itself (mostlikely for amavis scanning), so my question: Is amavis running?

    check if all daemons are running that need to run.
     
  3. MrMoo

    MrMoo New Member

    i have checked and it seems the amavisd and clam services are running, here is a list of whats running


    i have however recieved a few delayed delivery notifications from hotmail when sending to my domain, i had nothing waiting in any mail queues on the domain

     
    Last edited: Sep 21, 2011
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What tutorial (URL) did you use to set up the system? Is it one of the Postfix + MySQL tutorials? If so, did you exclude Postfix from updates? Because the standard Postfix packages for CentOS 5.x don't have MySQL support compiled in.
     
  5. MrMoo

    MrMoo New Member

    i have fixed it now,

    for some reason postfix failed to start, discovered this after trying to telnet to the various ports my main server is up and running now.

    thanks for your assistance..... time to get my new centOS 6 server working now.
     

Share This Page