Update your client software to continue using Let's Encrypt

Discussion in 'General' started by vassilis3, Mar 10, 2020.

  1. till

    till Super Moderator Staff Member ISPConfig Developer

    The command is:

    /usr/local/bin/certbot-auto --install-only

    otherwise certbot-auto would try to configure certs in apache on its own which then breaks ISPConfig.
     
  2. vassilis3

    vassilis3 Member

    Thank you Till,
    Could you tell me how to fix it'?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    I posted the command that you shall run instead:

    /usr/local/bin/certbot-auto --install-only
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    And I mentioned how to fix the bad .vhost issue (just remove the sites-enabled symlink).
     
  5. vassilis3

    vassilis3 Member

    I ran it but the sites are still down
     
  6. vassilis3

    vassilis3 Member

    Thank you Jesse
    I did it
    same problem
    upload_2020-3-23_20-40-19.png
     
    Last edited: Mar 23, 2020
  7. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Run those commands shown in your error for details on what the problem is. You can probably also get them from running 'apachectl configtest'. You may have more bad vhost files you need to fix (eg. temporarily remove), or ??
     
  8. vassilis3

    vassilis3 Member

    upload_2020-3-23_21-12-44.png

    upload_2020-3-23_21-14-56.png

    upload_2020-3-23_21-21-19.png
     
  9. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    There you go, same problem as the last time. The fix of course is the same, too.
     
  10. vassilis3

    vassilis3 Member

    I'm sorry but I don't understand what you mean
    What problem did you see? and how do I fix it?
    Do you mean to remove every domain appears under /etc/apache2/sites-enabled/ when this error appears "AH00526: Syntax error on line 121"
     
    Last edited: Mar 23, 2020
  11. Steini86

    Steini86 Active Member

    Basically yes. The error is that there is still a LetsEncrypt certificate used in these files. That is why before deleting the certificates you should deactivate the "LetsEncrypt" checkbox in ISPC. Because you missed that, you get these errors. So for every domain where you have deleted the certificate and did not deactivate it in ispc before, you will get this error. The solution is do delete the web in sites-enabled. Then this web will not be started. Then, when Apache is running again, you bring back LetsEncrypt and reactivate one web after the other with LetsEncrypt.
     
    till likes this.
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess the main problem is that he used certbot on the shell with the apache module, files with -le-ssl.conf in the name are a clear indication for that, and this must break the systems s ispconfig is not able to manage these sites anymore due to the duplicated config. So all files with -le-ssl.conf in their name where the domain is managed in ISPconfig has to be removed anyway to get a working system back.
     
  13. vassilis3

    vassilis3 Member

    After few deletes Apache started again.
    upload_2020-3-23_22-54-37.png
    but even though I check SSL and Letsencrypt boxes, they uncheck themselves
    also the sites show the Apache default page
     
  14. vassilis3

    vassilis3 Member

    I have removed everything.
    This is the current state.
    upload_2020-3-23_23-2-52.png
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

  16. vassilis3

    vassilis3 Member

  17. vassilis3

    vassilis3 Member

    Αnd the last problem was solved I made this change and everything works again.

    "- When your server is behind a NAT router so that the server itself can not reach the hosted domains, then enable the option "Skip Letsencrypt check" under System > Server config > web."

    Thank you all for help.
     
    Last edited: Mar 23, 2020
    Steini86 likes this.

Share This Page