Update to latest version end up ISPConfig as inaccessible

Discussion in 'ISPConfig 3 Priority Support' started by Quaxth, Jun 3, 2017.

  1. Quaxth

    Quaxth Member HowtoForge Supporter

    As the title say.

    After I updated the ISPConfig 3.1.2 to 3.1.3, my Log On hasn't accepted anymore.

    [​IMG]
    Just to mention: Username and Password are correct!


    It's not only that, the startup to ISPConfig is gone to be very slow since the update!
    Also, the via ISPConfig/Softaculous installed OwnCloud, could not be started anymore. That installation was working well on 3.1.2 with no problems!

    Any Idea what could have gone wrong? Please advice. Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    An ISPConfig update does not has any influence on an installed Owncloud instance as the ISPConfig update does not alter any existing websites. Maybe you installed other updates like Linux updates as well at the same time or did any other administrative tasks on that server whicg caused the issue. So my guess is that there is a different problem independent form the ISPConfig update that affects Owncloud and ISPConfig.

    Try to restart MySQL, maybe it is stopped, as this would explain the owncloud and ISPConfig error.

    If a MySQL or server restart did not help, then you should check the Linux syslog and the global apache error.log for errors and also the error.log of the owncloud website.
     
  3. Quaxth

    Quaxth Member HowtoForge Supporter

    You're right, I done the Linux Update first, and after done started ISPOConfig, which wasn't a problem, as well the same for OwnCloud. Only after done the ISPConfig update to 3.1.3, I wasn't able to Log On, Username and/or Password was rejected. Then started OwnCloud, ended up in error:
    [​IMG]
    This is what I get on screen to open/start OwnCloud!

    After try to restart MySQL, same error occurs again!

    Any idea? Thanks.
     
  4. Quaxth

    Quaxth Member HowtoForge Supporter

    Tried to restart MySQL again and couldn't get an error message with more info running the 2 suggested command, pls look at the picture!:
    [​IMG]
     
  5. Quaxth

    Quaxth Member HowtoForge Supporter

    What I've to do to solve that problems?

    Thanks for any advice.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so your problem is not related to the ISPconfig update at all, the problem is caused by MySQL (probably you installed a MySQL update with the system updates that failed). That Owncloud and ISPConfig are not working are the symptoms of the MySQL failure as neither Owncloud nor ISPConfig will work without MySQL.

    To find the reason for the MySQL failure, look into the MySQL log files and the Linux syslog.
     
  7. Quaxth

    Quaxth Member HowtoForge Supporter

    Thanks for your answer Till!
    I'd done the suggested Backup before upgrading Linux, and ISPConfig.
    After the Upgrade of Linux, I'd run ISPC and OwnCloud, which worked as they should. Following I upgraded ISPConfig, and after that, I got the error at the same moment I was trying to run OwnCloud and ISPConfig.
    It doesn't matter what Upgrades I do on my system's, always, I run the needed apps after each single upgrade, for to be sure that all is still Ok!
    So question now, How could I restore the Backup? I would appreciate a detailed advice. Thanks.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please look at the Linux syslog and the mysql.log file to find the error in MySQL. What you can try is that you restore the mysql config files from the etc.tar.gz that you find in the most recent backup folder in /var/backup/ispconfig* and then restart mysql.
     
  9. Quaxth

    Quaxth Member HowtoForge Supporter

    Hi, and sorry for answer soooooo late, I just back from Overseas trip to Australia.

    The MySQL Problem still exist on my server and I'm not able to start ISPConfig.
    I found the latest Backup:
    [​IMG]
    Could you please give me the command for to restore the MySQL config?

    Thanks a lot.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Unpack the etc tar.gz backup file. inside you can find mysql/my.cnf. Copy this my.cnf file to /etc/mysql/ folder of your system and overwrite the file that you find there.
     
  11. Quaxth

    Quaxth Member HowtoForge Supporter

    OK, thanks. Done that and waiting now for a reboot of the server!
     
  12. Quaxth

    Quaxth Member HowtoForge Supporter

    Still, can not start ISPConfig.! Where do I look for the Syslog files for (Apache, MySQL etc.)? Thanks for your answer.
     
  13. Quaxth

    Quaxth Member HowtoForge Supporter

    Or, would an Upgrade top latest ISPC do the work?

    Thanks for any more advice!
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    /var/log/

    The reason for your problem is not related to ISPConfig, I told you that right at the beginning but you won't believe me anyway ;) But of course, you can continue to search in that direction if you like, it will just not solve your problem. Your problem is that your MySQL server is broken and does not start, that ISPConfig does not work is just a symptom for the failed MySQL same with the non working owncloud.
     
  15. Quaxth

    Quaxth Member HowtoForge Supporter

    Thanks Till! It's not that I didn't believe you, may I just got confused because using the Perfect Server Install Tuto for that installation and all are together in there!
    That said, I'd already realized that my install (MySQL or MariaDB) is broken.
    So, question: could I just re-install MySQL/MariaDB Server and that would work, or would it be better for to dfo a complete and clean install of Debian and ISPConfig?

    Thanks for your advice.
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    I would do neither nor. Please look at the log files in the directory I mentioned and post the mysql error that you will find there.
     
  17. Quaxth

    Quaxth Member HowtoForge Supporter

    Thanks.
    OK, here we go:
    MySQL Log: all are empty, 0 bytes!
    Syslog: 2 files with 6xx KB size, just couldn't be opened, and nano shows show not any content!
    [​IMG]

    What else I could/should look for?

    Thanks a lot.
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Log files are normally viewed with the tail command. Restart mysql and then run:

    tail -n 100 /var/log/syslog

    to view the last 100 lines of the log file. Opening the file with nano failed as you tried to open /etc/log/syslog instead of /var/log/syslog according to your screenshot.
     
  19. Quaxth

    Quaxth Member HowtoForge Supporter

    Thanks Till.

    I was try to restart the MySQL Service, but failed:

    [​IMG]

    What would be the next to do for me?

    Thanks for your advice.
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, this is expected as it failed before. you should restart it to ensure that the failure is written to the end of the log file again.

    Look at the /var/log/syslog file as I mentioned above. I posted the tail command to get the error messages.
     

Share This Page