update to 3.1 on slave mail server gets ssl cert broken?

Discussion in 'Installation/Configuration' started by ron_aa, Oct 5, 2016.

  1. ron_aa

    ron_aa New Member

    I've updated to 3.1 on the master server without any problems (some small login issues on the admin panel in chrome/firefox but internet explorer works so I'll figure that out later)... anyways, when I update ISPC on the dedicated mail server (slave) everything seems to go fine until I try to connect with an email client: then warnings pop up that a self signed cert is being used where before a positive ssl cert was active. I've tried updating with both 'reconfigure services' yes and selected, resulting in the same error. And for the life of me I can't figure out where to fix this (I've checked the postfix and dovecot ssl settings and also did an ls -l in /etc/ssl and all these files seem to be unchanged). It's late and I'm probably missing something obvious but any help is appreciated.

    debian jessie / dovecot / postfix / ISPC 3.1 (master) and 3.0.5.4p9 (slaves)

    Let's hope not too many out-of-offices etc will be set before I get this fixed... not looking forward to multiple database replication error mail messages being sent every minute ;) For now I'm just restoring a snapshot so people will be able to start emailing in the morning without having to accept a self signed cert.
     
    Last edited: Oct 5, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's not an issue in ISPConfig. I guess you installed a signed ssl cert the wrong way before so that it was not update safe. Never alter paths to ssl certs in config files of postfix, dovecot, courier or the apache vhost. If you want to replace an ssl cert, then replace the file without altering the path or use a symlink to point the original path to the place where your new ssl cert and key is located.
     
  3. ron_aa

    ron_aa New Member

    Sorry for the late reply and the original question even, after waking up this morning the brain was functioning again and everything was fixed within 5mins, with - surprise surprise - symlinks.
     
  4. harshu294

    harshu294 Member

    When i tried to upgrade from 3.0 to 3.1 its giving me below error.
    Unable to retrieve version file.
    I am having master and slave DNS server.
    I first tried to update master DNS.
    Kindly let me know wht to do?
    why this error is coming?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Your server or network blocks the updater so he can not reach ispconfig.org.
     
  6. harshu294

    harshu294 Member

     
  7. harshu294

    harshu294 Member

    Thanks for the response.
    I updated both master and slave server to 3.1 .
    During updation i got the below error:
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 21: -d: command not found
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 26: syntax error near unexpected token `else'
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 26: `else'
    /usr/local/bin/ispconfig_update.sh: line 4: ate.php: command not found
    What this means?
    Did i missed anything?

    Post updation when i tried to add new zone. I am facing below mentioned issues :
    1)when i import zone file,its is getting created with .err extension such as pr.example.com.err
    2)named.conf.local is not getting updated with new domain as i added new zone file.
    3)But the same is not happening when i create new Zone manually via ISPConfig webadmin panel.
    Before upgrade everything was working fine.

    How to fix this issue?
    Please treat this urgent.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This has been answered at least in a dozen posts and in the bugtracker.

    The .err extension means that the zone file is incomplete or wrong. check the records in ispconfig to see what you missed to add.
     
  9. harshu294

    harshu294 Member

     
  10. harshu294

    harshu294 Member

    Thanks again for quick response.
    told earlier the same was working fine before update.
    After update I just removed that zone file and again imported the same.
    Now how come it is having syntax error? Please note i want to make this server live ASAP.
    Here i am attaching the zone file which i tried to import.
    Please let me know if i missed something.
     

    Attached Files:

  11. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use the named-checkzone command to see why named rejected the zone.
     
  12. leonardo.saracini

    leonardo.saracini New Member

    When I have updated mine form 3.0 to 3.1 I have got the same harshu294 error:
    Code:
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 21: -d: command not found
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 26: syntax error near unexpected token `else'
    /usr/local/ispconfig/server/scripts/update_from_tgz.sh: line 26: `else'
    /usr/local/bin/ispconfig_update.sh: line 4: ate.php: command not found
    so I look at update_from_tgz.sh code and see that the error fired after download and decompress file and cd to a folder.
    I then do it one more time: /usr/local/ispconfig/server/scripts/update_from_tgz.sh and this time go head.
    I do not know if this is right procedure: is just what is happened to me.
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    This question has been answered so many times in the forum and also in the bugtracker so I will not answer it again. Please use the search function before you ask the same things again.
     
  14. harshu294

    harshu294 Member

    I want to import 800 zone file from old bind to isp config 3.
    Do u have any quick method/script for this?
    Please treat this urgent.
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    And how is this related to the thread topic "update to 3.1 on slave mail server gets ssl cert broken"? Please do not hijack other threads with a different topic!

    You can e.g. use the remote API to write a script to import your zones. The remote API examples are in the remote_client folder of the ispconfig tar.gz file.

    And you you need urgent support, then contact the business support: http://www.ispconfig.org/get-support/?type=ispconfig
     

Share This Page