update to 3.1.13, ubuntu 16 server, letcencrypt: could not be issued

Discussion in 'Installation/Configuration' started by nopanic, Aug 20, 2018.

  1. nopanic

    nopanic New Member

    Hello all,

    I just did an update to ispconfig 3.1.13. Afterwards I want to create a domain: third.level.top.
    Generating the letsencrpt certificates gives in ispconfig.log a warning:
    WARNING - Let's Encrypt SSL Cert for:third.level.top.could not be issued.

    in letsencrypt.log:
    File "/usr/lib/python2.7/dist-packages/letsencrypt/client.py", line 116, in register
    acme = acme_from_config_key(config, key)
    File "/usr/lib/python2.7/dist-packages/letsencrypt/client.py", line 41, in acme_from_config_key
    return acme_client.Client(config.server, key=key, net=net)
    File "/usr/lib/python2.7/dist-packages/acme/client.py", line 63, in __init__
    self.net.get(directory).json())
    File "/usr/lib/python2.7/dist-packages/acme/messages.py", line 169, in from_json
    raise jose.DeserializationError(str(error))
    DeserializationError: Deserialization error: Wrong directory fields


    Trying another domain, did also a reboot.... all the same.

    Can someone help?

    Tia
    Stefan
     
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Code:
    mkdir /opt/certbot
    cd /opt/certbot
    wget https://dl.eff.org/certbot-auto
    chmod a+x ./certbot-auto
    ./certbot-auto
    mv /usr/bin/letsencrypt /usr/bin/letsencrypt~
    
     
    Last edited: Aug 22, 2018
  3. nopanic

    nopanic New Member

Share This Page