Update to 3.1.1 broke email

Discussion in 'Installation/Configuration' started by Steffan, Oct 26, 2016.

  1. Steffan

    Steffan Member

    Hello,

    after updating from 3.1 to 3.1.1 postfix would started
    the problem was that port 10025 was in use
    The old config had:
    master.cf~:10025 inet n - n - - smtpd

    The new config had:
    master.cf:10025 inet n - n - - smtpd
    master.cf:127.0.0.1:10025 inet n - n - - smtpd

    Also the ssl cert location was change back to default so the let's encryp certs wasnt loaded

    And all dkim_key lines in /etc/amavisd/amavisd.conf was removed
    Did i do something wrong or???
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The new config is fine, port 10025 has to be bound to localhost IP. Your old config opened amavis for direct access from outside. Beside that, the postfix config has not been changed from 3.1 to 3.1.1, the port was bound to 127.0.0.1 in ispconfig 3.1 and 3.0.5 as well.

    Then you installed your custom ssl cert wrong. The paths of the ssl should never be changed for a custom cert. If you want to use a custom cert then you use a symlink as described in this guide: https://www.howtoforge.com/securing...h-a-free-class1-ssl-certificate-from-startssl The provcedure for other ssl authorities like letsencrypt is the same.
     
  3. Steffan

    Steffan Member

    thanxs
    oke i changed it in 127.0.0.1 en removed the other
    also changed the ssl

    but what abouth the dkim_key
    the lines ware removed from the config

    also i have /etc/postfix/dkim in the mailsettings
    but the last 2 keys ware created today in /var/lib/amavis/dkim/
     
  4. Jesse Norell

    Jesse Norell Active Member

    Did you install OS package updates by chance? Re-run the updater and answer yes to the 'reconfigure services' question, it should put the needed config back.
     
  5. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    ISPConfig 3.1 stores the dkim-keys /var/lib/amavis/dkim/ or whatever you defined for the server. I can't remember, taht ispconfig wrote dkim-keys to /etc/posftix/dkim (by default).
     
  6. Steffan

    Steffan Member

    it is a setting in the controlpanel. it was ignored after the update
    also the spamfiltyers ware removed.
    After deleting the entry
    Save
    enter the entry
    Save

    it works again.
     

Share This Page