update to 2.2.16 makes error

Discussion in 'Installation/Configuration' started by luchs3, Sep 15, 2007.

  1. luchs3

    luchs3 New Member

    Hi,

    I tried to update from 2.2.15 to the latest version.
    Everything worked fine until I got this Error:
    .

    Now the admin Site doesn't work and if I try to install the 2.2.16 again the Setup doesn't seem to find the old installation and wants to install everything new.

    Luckily the customer Webs are still working

    Server OS: Ubuntu 7.04

    I would be very happy if anyone has an idea to solve this problem.

    Thanks Niko
     
  2. till

    till Super Moderator

    To run the update script again, you must first run:

    mkdir /root/ispconfig

    then the installer will be able to recognize the old installation again. To help you wth your original problem, please post the first error(s) from the compile output and not just the last error.
     
  3. luchs3

    luchs3 New Member

    Error Message

    Here we go.
    I don't know where the Error starts.
    Between the libtool part and the libclamv part are a lot of unreadable lines.

    Code:
    ../libtool: command substitution: line 2326: syntax error near unexpected token `('
    ../libtool: command substitution: line 2326: `������E�������E���$������p�4$�Z����U����B� ��t�$�L$�9����������D$��$������U�����_�E
    ...(unreadable text)...
    ./libtool: line 2326:
    |
    �
    �$|
    �$�
    �$�
    �$�
    �$�
    �$�
    �$�
    �$
    �$
    �$
    ...
    
    make[2]: *** [libclamav.la] Error 1
    make[2]: Leaving directory `/home/webadmin/install_ispconfig/compile_aps/clamav-0.91.2/libclamav'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/webadmin/install_ispconfig/compile_aps/clamav-0.91.2'
    make: *** [all] Error 2
    ERROR: Could not make ClamAV
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 873: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: Das mitgelieferte PHP-Binary funktioniert auf Ihrem System nicht! Die Installation bricht hier ab!
    
     
  4. till

    till Super Moderator

    Did you change the shell as described in the perfect setup?

    rm -f /bin/sh
    ln -s /bin/bash /bin/sh

    Is your system up to date?
     
  5. luchs3

    luchs3 New Member

    shure, system is up to date.
    I installed the 2.2.15 with the "perfect setup..".

    I also tried ti compile it with the gcc-3.4 and g++-3.4 but there is no difference.

    I even can't install the 2.2.15 again, I get the same Error.
     
    Last edited: Sep 17, 2007
  6. till

    till Super Moderator

    Have a look at your /tmp directory, you should find there some tar.gz backup files. If you untar the oldest files (from the day you started the first upgrade attempt) and copy the contents with preseverd permissions to /root/ispconfig and /home/admispconfig, you should get at least a working 2.2.15 system back until we find a solution for your compile problem.
     
  7. luchs3

    luchs3 New Member

    Sounds nice but in my /tmp folder are just some sess_1234... files.

    Is there another possibility to restore the server?
     

Share This Page