Update Status

Discussion in 'General' started by onastvar, Nov 29, 2010.

  1. onastvar

    onastvar Member

    I have the following warnings in my ISPConfig 3.0.3 on Debian 5. Should I be concerned, anyone knows how to fix it?

    Update Status page

    Reading package lists...
    Building dependency tree...
    Reading state information...
    The following packages will be upgraded:
    base-files dpkg dpkg-dev imagemagick libmagick10 linux-libc-dev
    6 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Inst base-files [5lenny7] (5lenny8 Debian:5.0.7/stable)
    Conf base-files (5lenny8 Debian:5.0.7/stable)
    Inst dpkg [1.14.29+b1] (1.14.30 Debian:5.0.7/stable)
    Conf dpkg (1.14.30 Debian:5.0.7/stable)
    Inst dpkg-dev [1.14.29] (1.14.30 Debian:5.0.7/stable)
    Inst libmagick10 [7:] (7: Debian:5.0.7/stable)
    Inst imagemagick [7:] (7: Debian:5.0.7/stable)
    Inst linux-libc-dev [2.6.26-25lenny1] (2.6.26-26lenny1 Debian-Security:5.0/stable)
    Conf dpkg-dev (1.14.30 Debian:5.0.7/stable)
    Conf libmagick10 (7: Debian:5.0.7/stable)
    Conf imagemagick (7: Debian:5.0.7/stable)
    Conf linux-libc-dev (2.6.26-26lenny1 Debian-Security:5.0/stable)
    Show ISPC Cron Jobs page

    W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
    W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
    Reading changelogs...
    debconf: unable to initialize frontend: Dialog
    debconf: (TERM is not set, so the dialog frontend is not usable.)
    debconf: falling back to frontend: Readline
    debconf: unable to initialize frontend: Readline
    debconf: (This frontend requires a controlling tty.)
    debconf: falling back to frontend: Teletype
    dpkg-preconfigure: unable to re-open stdin:
    W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if some debian packages are missing to run apt- Try to update the system manually on the shell with the commands:

    apt-get update
    apt-get upgrade
  3. ande

    ande Member HowtoForge Supporter

    Had the same problem (ISPConfig 3 on Debian 6, out of the box). apt-get update / upgrade didnt help..

    I know that Debian tries to find out how to get into dialog with me when running the scripts. It doesnt bother me, but would be nice to avoid this reappearing every now and again..

Share This Page