update services on ubuntu

Discussion in 'HOWTO-Related Questions' started by kwickcut, Feb 11, 2011.

  1. kwickcut

    kwickcut Member

    update packages on ubuntu

    i am running Ubuntu Linux 9.10 and have not checked on it for a bit. today i logged into webmin and found i had 88 package updates. i ran the updater and they all failed what should i do to force them to update?


    thanks
    kwick
     
    Last edited: Feb 11, 2011
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the error message you got?
     
  3. kwickcut

    kwickcut Member

    this is just a few they are all the same

    Code:
    Now updating apache2 ..
    
          Installing package(s) with command apt-get -y install apache2 ..
    
          dpkg: dependency problems prevent configuration of webmin:
           webmin depends on apt-show-versions; however:
            Package apt-show-versions is not installed.
          dpkg: error processing webmin (--configure):
           dependency problems - leaving unconfigured
          Errors were encountered while processing:
           webmin
          Reading package lists...
          Building dependency tree...
          Reading state information...
          You might want to run `apt-get -f install' to correct these:
          The following packages have unmet dependencies:
            apache2: Depends: apache2-mpm-worker (>= 2.2.12-1ubuntu2.4) but it is not going to be installed or
                              apache2-mpm-prefork (>= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed or
                              apache2-mpm-event (>= 2.2.12-1ubuntu2.4) but it is not going to be installed or
                              apache2-mpm-itk (>= 2.2.12-1ubuntu2.4) but it is not going to be installed
                     Depends: apache2.2-common (= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed
            webmin: Depends: apt-show-versions but it is not going to be installed
          E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
          .. install failed!
    
    
    Now updating apache2-doc ..
    
          Installing package(s) with command apt-get -y install apache2-doc ..
    
          dpkg: dependency problems prevent configuration of webmin:
           webmin depends on apt-show-versions; however:
            Package apt-show-versions is not installed.
          dpkg: error processing webmin (--configure):
           dependency problems - leaving unconfigured
          Errors were encountered while processing:
           webmin
          Reading package lists...
          Building dependency tree...
          Reading state information...
          You might want to run `apt-get -f install' to correct these:
          The following packages have unmet dependencies:
            webmin: Depends: apt-show-versions but it is not going to be installed
          E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
          .. install failed!
    
    
    Now updating apache2-mpm-prefork ..
    
          Installing package(s) with command apt-get -y install apache2-mpm-prefork ..
    
          dpkg: dependency problems prevent configuration of webmin:
           webmin depends on apt-show-versions; however:
            Package apt-show-versions is not installed.
          dpkg: error processing webmin (--configure):
           dependency problems - leaving unconfigured
          Errors were encountered while processing:
           webmin
          Reading package lists...
          Building dependency tree...
          Reading state information...
          You might want to run `apt-get -f install' to correct these:
          The following packages have unmet dependencies:
            apache2-mpm-prefork: Depends: apache2.2-common (= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed
                                 Depends: apache2.2-bin (= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed
            webmin: Depends: apt-show-versions but it is not going to be installed
          E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
          .. install failed!
    
    
    Now updating apache2-suexec ..
    
          Installing package(s) with command apt-get -y install apache2-suexec ..
    
          dpkg: dependency problems prevent configuration of webmin:
           webmin depends on apt-show-versions; however:
            Package apt-show-versions is not installed.
          dpkg: error processing webmin (--configure):
           dependency problems - leaving unconfigured
          Errors were encountered while processing:
           webmin
          Reading package lists...
          Building dependency tree...
          Reading state information...
          You might want to run `apt-get -f install' to correct these:
          The following packages have unmet dependencies:
            webmin: Depends: apt-show-versions but it is not going to be installed
          E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
          .. install failed!
    
    
    Now updating apache2-utils ..
    
          Installing package(s) with command apt-get -y install apache2-utils ..
    
          dpkg: dependency problems prevent configuration of webmin:
           webmin depends on apt-show-versions; however:
            Package apt-show-versions is not installed.
          dpkg: error processing webmin (--configure):
           dependency problems - leaving unconfigured
          Errors were encountered while processing:
           webmin
          Reading package lists...
          Building dependency tree...
          Reading state information...
          You might want to run `apt-get -f install' to correct these:
          The following packages have unmet dependencies:
            apache2-utils: Depends: libssl0.9.8 (>= 0.9.8g-16ubuntu3.2) but 0.9.8g-16ubuntu3.1 is to be installed
            webmin: Depends: apt-show-versions but it is not going to be installed
          E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
          .. install failed!
    
    
    Now updating apache2.2-bin ..
    
          Installing package(s) with command apt-get -y install apache2.2-bin ..
    
          dpkg: dependency problems prevent configuration of webmin:
           webmin depends on apt-show-versions; however:
            Package apt-show-versions is not installed.
          dpkg: error processing webmin (--configure):
           dependency problems - leaving unconfigured
          Errors were encountered while processing:
           webmin
          Reading package lists...
          Building dependency tree...
          Reading state information...
          You might want to run `apt-get -f install' to correct these:
          The following packages have unmet dependencies:
            apache2-mpm-prefork: Depends: apache2.2-bin (= 2.2.12-1ubuntu2.2) but 2.2.12-1ubuntu2.4 is to be installed
            apache2.2-bin: Depends: libssl0.9.8 (>= 0.9.8g-16ubuntu3.2) but 0.9.8g-16ubuntu3.1 is to be installed
            apache2.2-common: Depends: apache2.2-bin (= 2.2.12-1ubuntu2.2) but 2.2.12-1ubuntu2.4 is to be installed
            webmin: Depends: apt-show-versions but it is not going to be installed
          E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
          .. install failed!
    
    
    Now updating apache2.2-common ..
    
          Installing package(s) with command apt-get -y install apache2.2-common ..
    
          dpkg: dependency problems prevent configuration of webmin:
           webmin depends on apt-show-versions; however:
            Package apt-show-versions is not installed.
          dpkg: error processing webmin (--configure):
           dependency problems - leaving unconfigured
          Errors were encountered while processing:
           webmin
          Reading package lists...
          Building dependency tree...
          Reading state information...
          You might want to run `apt-get -f install' to correct these:
          The following packages have unmet dependencies:
            apache2: Depends: apache2.2-common (= 2.2.12-1ubuntu2.2) but 2.2.12-1ubuntu2.4 is to be installed
            apache2-mpm-prefork: Depends: apache2.2-common (= 2.2.12-1ubuntu2.2) but 2.2.12-1ubuntu2.4 is to be installed
            apache2.2-common: Depends: apache2.2-bin (= 2.2.12-1ubuntu2.4) but 2.2.12-1ubuntu2.2 is to be installed
            webmin: Depends: apt-show-versions but it is not going to be installed
          E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
          .. install failed!
    
    
    Now updating bind9-host ..
    
          Installing package(s) with command apt-get -y install bind9-host ..
    
          dpkg: dependency problems prevent configuration of webmin:
           webmin depends on apt-show-versions; however:
            Package apt-show-versions is not installed.
          dpkg: error processing webmin (--configure):
           dependency problems - leaving unconfigured
          Errors were encountered while processing:
           webmin
          Reading package lists...
          Building dependency tree...
          Reading state information...
          You might want to run `apt-get -f install' to correct these:
          The following packages have unmet dependencies:
            bind9-host: Depends: libbind9-50 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
                        Depends: libdns53 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
                        Depends: libisc50 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
                        Depends: libisccfg50 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
                        Depends: liblwres50 (= 1:9.6.1.dfsg.P1-3ubuntu0.4) but 1:9.6.1.dfsg.P1-3ubuntu0.3 is to be installed
            webmin: Depends: apt-show-versions but it is not going to be installed
          E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    
          .. install failed!
    thanks for any input

    kwick
     
  4. kwickcut

    kwickcut Member

    problem solver i had to install apt-show-versions and also had to forward port 22 i always did everything on box



    kwick
     

Share This Page