1. After running what looked like a successful update none of my websites work & I can not login to the ISPconfig (control panel). httpd will not run.

    If I try to start the system manually...

    Starting ISPConfig system...
    /etc/rc.d/init.d/ispconfig_server: line 45: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    /etc/rc.d/init.d/ispconfig_server: line 48: /root/ispconfig/php/php: No such file or directory
    ISPConfig system is now up and running!

    the last part is not correct - it's not up & running

    any help would be most appreciated
  2. vicboy

    vicboy New Member

    clamav compiled correctly?

    I had an error while installing (but in the end, the installer told me it was OK). I've seen some errors that I never found before while upgrading, so I tried to login to the control panel and it didn't work. Normal webserver (port 80) didn't work neither.

    So I tried to run ./setup again, looking through messages: it stopped while compiling clamAV (then, it didn't ask me the administrator's mail for SpamAssassin), and tried to run some other files, but the whole install_ispconfig was deleted.

    After some research on the install files, I found that I could avoid the clamAV installation by editing install_ispconfig/compile_aps/compile and removing some lines there; then it worked OK.

    It happened to me in a Fedora 7 install working right, and with previous upgrades with no problems. I've also upgraded some hours before 3 different Fedora version's servers with no problems.

    I don't know it that could cause you the problems. Here's it's midnight now so I'll go to sleep -server's just working now- and tomorrow I'll see if I can tell which was the exact reason or if I could do something to clamAV before (but I never use antivirus on mailboxes in that server and I never touched its config or files; and the server hasn't been restarted 'till two or three previous upgrades.....!

    Hope that helps a bit for if someone has the same problem. If it isn't related, just delete it !!! ;)

    PS: I've seen the error I got during installation on other boards. Here's the message:

    Last edited: Nov 6, 2009
  3. Hans

    Hans Moderator ISPConfig Developer

    @ Both, which distribution do you use?
    I did an upgrade on Debian Lenny, and the upgrade went fine for me...
  4. vicboy

    vicboy New Member


    Mine failed on Fedora 7. But I've upgraded two more servers running FC5 and worked fine. As I told you I removed the ClamAV installation lines from the install_ispconfig/compile_aps/compile script and then everything "worked". The error was caused by a failing clamav install that removed the entire install_ispconfig directory, so then the other scripts couldn't be run. Avoiding the clamAV install helped me recover the server, but without upgrading the antivirus of course :)
    Last edited: Nov 6, 2009
  5. ybz

    ybz New Member

    I'm using Ubuntu Server 9.10. Same behaviour.
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    df -h
  7. ybz

    ybz New Member

    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 227G 4.8G 211G 3% /
    udev 497M 252K 497M 1% /dev
    none 497M 940K 496M 1% /dev/shm
    none 497M 132K 497M 1% /var/run
    none 497M 0 497M 0% /var/lock
    none 497M 0 497M 0% /lib/init/rw
  8. falko

    falko Super Moderator ISPConfig Developer

    Ok, I was guessing that hard drive space might be the problem, but this is not the case... :confused:
  9. ybz

    ybz New Member

    What about the calmAV issues mentioned above? Are they not relevant?
  10. falko

    falko Super Moderator ISPConfig Developer

    As far as I know, ClamAV compiles correctly on Ubuntu. The only distribution where it doesn't seems to be Fedora.
  11. ybz

    ybz New Member

    After many trials, I had no other choice but to re-install the system (following your recommended instructions for Ubuntu Server 9.10). While doing that I've noticed that there is a new comment at the end of the article under section 22 (about replacing getline with parseline in the /usr/include/stdio.h file. see: http://www.howtoforge.com/perfect-server-ubuntu-9.10-karmic-koala-ispconfig-2-p7).

    In the previous installation, I have started with version 9.04 + ISPConfig 2. Then I have upgraded to 9.10 and upgraded to ISPconfig 2.2.34. Could be that the reason for the fault mentioned above is due to the additional comment you made under section 22?
  12. falko

    falko Super Moderator ISPConfig Developer

    I don't think this has anything to do with your ClamAV problems.
  13. ybz

    ybz New Member

    The problem was not with ClamAV (this is something suggested above by others). The problem was with missing elements (see above) that did not enable to restart ISPconfig_server:

    Starting ISPConfig system...
    /etc/rc.d/init.d/ispconfig_server: line 45: /root/ispconfig/httpd/bin/apachectl: No such file or directory
    /etc/rc.d/init.d/ispconfig_server: line 48: /root/ispconfig/php/php: No such file or directory
  14. IgorS3

    IgorS3 New Member

    Same problem with Ubuntu 9.10
    make[2]: Entering directory `/home/***/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    gcc -c -I../os/unix -I../include -DLINUX=22 -DHAVE_SET_DUMPABLE -DMOD_SSL=208131 -DUSE_HSREGEX -DEAPI `../apaci` htpasswd.c
    htpasswd.c:101: error: conflicting types for 'getline'
    /usr/include/stdio.h:651: note: previous declaration of 'getline' was here
    make[2]: *** [htpasswd.o] Error 1
    make[2]: Leaving directory `/home/***/install_ispconfig/compile_aps/apache_1.3.41/src/support'
    make[1]: *** [build-support] Error 1
    make[1]: Leaving directory `/home/***/install_ispconfig/compile_aps/apache_1.3.41'
    make: *** [build] Error 2
    Last edited: Nov 18, 2009
  15. falko

    falko Super Moderator ISPConfig Developer

    Take a look at chapter 22 on http://www.howtoforge.com/perfect-server-ubuntu-9.10-karmic-koala-ispconfig-2-p7
  16. ybz

    ybz New Member

    So, you agree that the addition in chapter 22 makes the difference? ;-)

Share This Page