Update PHP safely

Discussion in 'Installation/Configuration' started by L4ky, Sep 17, 2015.

  1. L4ky

    L4ky New Member

    Hi, i have a VPS running Centos 6.5 ISPConfig 3, nginx, PHP-fpm 5.3.3, phpmyadmin, mysql 5.6.26.

    I tried so many times to compile latest PHP version causing many problems in the server. Now i restored the original php 5.3.3 but when i join into phpmyadmin it says my php libs are older that mysql libs.

    Here what i tried, following tutorial found in these website about installing another php version ( multple ) :
    - Compile php 5.6.13 - NO SUCCESS at all, after ./configure with parameters it configured files with 5.6.0 versione ( WITHOUT any reason !! unbelievable )
    - Compile php 5.6.0 - NO SUCCESS
    In both cases i had an error about --with-imap parameters, it says: no libc-client.a found, even if it exists and linked into /usr/lib ( running updatedb then locate libc-client.a it get found ).

    I know the server runs well now, but i'd like to have everything updated to latest stable version..
    Can someone help me?

Share This Page