Update Manager on ISPconfig

Discussion in 'Installation/Configuration' started by techngo, Nov 27, 2005.

  1. techngo

    techngo New Member

    I tried to install the phpmyadmin update and I keep getting a php install error on line 40
    tmp_dir_error.
    I am runing Fedora 4 on a pIII box.
    used the perfect setup guide and got ispconfig installed and runing.

    I have tried using the url and downloading the package to my home folder and point to it using upload.

    Any ideas would be helpful. :eek:
    I am new to this
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    What is the exact error message you get?
     
  3. techngo

    techngo New Member

    ispconfig update manager

    Warning: mkdir() [function.mkdir]: No such file or directory in /home/admispconfig/ispconfig/web/admin/update/install.php on line 40
    The following error occurred:


    tmp_dir_error

    Thanks
     
  4. techngo

    techngo New Member

    ispconfig update manager

    :) I figured it out. I needed to creat a temp directory inside /home/admispconfig/ispconfig/web/admin/update then I had to give the ispadmin write priv.

    thanks for your reply though

    :eek:
     
  5. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    To create thi directory helped you to solve this problem temporaily, but its not a resolution, because the correct temp directory is here: /home/admispconfig/ispconfig/temp

    Hva e you changed someting in the ISPConfig php.ini or in the config.inc.php file of ISPConfig?
     
  6. techngo

    techngo New Member

    Update manager

    Of course you were right I had the path wrong on the temp directory.
    I was guessing on the locaction of the temp directory. the error message was not very specific.

    Also needed to put the right privlidges on the temp directory.
    How come the temp directory wasn't created during the ispconfig install?

    Thanks

    :)
     
  7. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    This directory: /home/admispconfig/ispconfig/temp was not created during install?
     
  8. techngo

    techngo New Member

    Update Manager

    No it did not :confused: I know this for a fact as I just completed the install for the second time. Both times were on a clean install, I could not run the update manager until I added the temp directory and added permissions to the folder for adminispconfig.

    Thanks
     
  9. bve32k

    bve32k New Member

    I am bring this thread back from the dead!

    I am having the same problem. I installed it 2 times now and that temp folder is still not being created so I created it manually. Now I am lost on what I have to do after that..Any help would be appreciated!

    Thanks, Ken

    Edit: Forgot to add I am using Fedora 6.
     
    Last edited: Nov 12, 2006
  10. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Please run:

     
  11. bve32k

    bve32k New Member

    Thanks..I tried it this morning and it woked perfect!
     
  12. louisgag

    louisgag New Member

    I had the same problem with my ISPconfig: could not update and temp dir wasnt present, used mkdir & chown to fix it.

    :)
     
  13. agaida

    agaida New Member

    I had the same problem with my ISPconfig..
    Kann mich meinen Vorschreibern nur anschlie├čen, Fix tuts. (CentOS 5.4 x64, frisch aufgesetzt mit Perfect Server, ISPconfig Version: 2.2.35)
     

Share This Page