update from ISPConfig to 3.1.1p1 - let's encrypt does't work

Discussion in 'Installation/Configuration' started by AlexeyS, Nov 18, 2016.

  1. AlexeyS

    AlexeyS New Member

    Server Debian 8.6
    after this update I can not use Lets Encrypt.
    The following steps have been taken:

    a) Update from ISPConfig to 3.1.1p1 in console with teh script ispconfig_update.sh - OK

    b) Install certbot with
    mkdir /opt/certbot
    cd /opt/certbot
    wget https //dl.eff.org/certbot-auto
    chmod a+x ./certbot-auto

    If I activate Lets Encrypt in webinterface, I get an email with the error "WARNING - Let's Encrypt SSL Cert for: ******* could not be issued."
    Ich have activated DEBUG for ISPConfig, there I also find the same error.

    What's wrong ?
    Many Thanks!
  2. AlexeyS

    AlexeyS New Member

    I've still searched further and found the following. The Script "apache2_plugin.inc.php" executes this command:
    'which letsencrypt certbot /root/.local/share/letsencrypt/bin/letsencrypt'
    I do not have a folder /root/.local/share/letsencrypt.
    What can I do now ?

    Many Thanks!
  3. AlexeyS

    AlexeyS New Member

    The error was found. Since I work in the system with another name, folder letsencrypt was saved under my home path /home/myname/.local/share/letsencrypt. I have copied this folder under root and it is now running.

Share This Page